]> git.pld-linux.org Git - SPECS.git/blob - python-hgtools.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / python-hgtools.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # test target [pytest-runner doesn't support build-base]
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Python 2 classes and setuptools plugin for Mercurial and Git repositories
8 Summary(pl.UTF-8):      Klasy Pythona 2 oraz wtyczka setuptools do repozytoriów Mercurial oraz Git
9 Name:           python-hgtools
10 Version:        6.5.1
11 Release:        5
12 License:        MIT
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/simple/hgtools/
15 Source0:        https://pypi.python.org/packages/source/h/hgtools/hgtools-%{version}.tar.gz
16 # Source0-md5:  ce8413687e43d5626cdcfee5024a9bc0
17 URL:            https://bitbucket.org/jaraco/hgtools/
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 %{?with_tests:BuildRequires:    python-backports.unittest_mock}
22 %{?with_tests:BuildRequires:    python-pytest >= 2.8}
23 %{?with_tests:BuildRequires:    python-pytest-runner}
24 BuildRequires:  python-modules >= 1:2.6
25 BuildRequires:  python-setuptools
26 BuildRequires:  python-setuptools_scm >= 1.9
27 %endif
28 %if %{with python3}
29 %{?with_tests:BuildRequires:    python3-backports.unittest_mock}
30 %{?with_tests:BuildRequires:    python3-pytest >= 2.8}
31 %{?with_tests:BuildRequires:    python3-pytest-runner}
32 BuildRequires:  python3-setuptools
33 BuildRequires:  python3-setuptools_scm >= 1.9
34 BuildRequires:  python3-modules >= 1:3.2
35 %endif
36 Requires:       python-modules >= 1:2.6
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 hgtools builds on the setuptools_hg plugin for setuptools. hgtools
42 provides classes for inspecting and working with repositories in the
43 Mercurial and Git version control systems (VCS).
44
45 %description -l pl.UTF-8
46 hgtools dobudowuje wtyczkę setuptools_hg dla setuptools. Zapewnia
47 klasy do przeglądania orazy pracy z repozytoriami systemów kontroli
48 wersji (VCS) Mercurial oraz Git.
49
50 %package -n python3-hgtools
51 Summary:        Python 3 classes and setuptools plugin for Mercurial and Git repositories
52 Summary(pl.UTF-8):      Klasy Pythona 3 oraz wtyczka setuptools do repozytoriów Mercurial oraz Git
53 Group:          Libraries/Python
54 Requires:       python3-modules >= 1:3.2
55
56 %description -n python3-hgtools
57 hgtools builds on the setuptools_hg plugin for setuptools. hgtools
58 provides classes for inspecting and working with repositories in the
59 Mercurial and Git version control systems (VCS).
60
61 %description -n python3-hgtools -l pl.UTF-8
62 hgtools dobudowuje wtyczkę setuptools_hg dla setuptools. Zapewnia
63 klasy do przeglądania orazy pracy z repozytoriami systemów kontroli
64 wersji (VCS) Mercurial oraz Git.
65
66 %prep
67 %setup -q -n hgtools-%{version}
68
69 %build
70 %if %{with python2}
71 %py_build %{?with_tests:test}
72 %endif
73
74 %if %{with python3}
75 %py3_build %{?with_tests:test}
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %py_install
83
84 %py_postclean
85 %endif
86
87 %if %{with python3}
88 %py3_install
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with python2}
95 %files
96 %defattr(644,root,root,755)
97 %doc CHANGES.rst LICENSE README.rst
98 %{py_sitescriptdir}/hgtools
99 %{py_sitescriptdir}/hgtools-%{version}-py*.egg-info
100 %endif
101
102 %if %{with python3}
103 %files -n python3-hgtools
104 %defattr(644,root,root,755)
105 %doc CHANGES.rst LICENSE README.rst
106 %{py3_sitescriptdir}/hgtools
107 %{py3_sitescriptdir}/hgtools-%{version}-py*.egg-info
108 %endif
This page took 0.154045 seconds and 3 git commands to generate.