]> git.pld-linux.org Git - SPECS.git/blob - python-django-celery.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-django-celery.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module  django-celery
6 Summary:        django-celery provides Celery intergration for Django
7 Name:           python-%module
8 Version:        2.5.1
9 Release:        0.9
10 License:        BSD
11 Group:          Development/Languages
12 Source0:        http://pypi.python.org/packages/source/d/%{module}/%{module}-%{version}.tar.gz
13 # Source0-md5:  4cfaa8e1ae3741ecd85a9cfe4af5e4dc
14 URL:            http://code.google.com/p/django-celery/
15 BuildRequires:  python-modules
16 BuildRequires:  python-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 BuildRequires:  sed >= 4.0
20 Requires:       python-celery >= %{version}
21 Requires:       python-django
22 Requires:       python-django-picklefield
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Provides Celery integration for Django; Using Django ORM and cache
28 backend for storing results, autodiscovery of task modules for
29 applications listed in INSTALLED_APPS, and more.
30
31 %prep
32 %setup -q -n %{module}-%{version}
33
34 %build
35 %py_build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 %py_install \
40         --root $RPM_BUILD_ROOT
41
42 %py_postclean
43
44 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/%{module}/tests
45 rm -rf $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc AUTHORS LICENSE README docs
53 %attr(755,root,root)%{_bindir}/djcelerymon
54 %{py_sitescriptdir}/djcelery
55 %if "%{py_ver}" > "2.4"
56 %{py_sitescriptdir}/django_celery-%{version}-*.egg-info
57 %endif
This page took 0.169548 seconds and 3 git commands to generate.