]> git.pld-linux.org Git - SPECS.git/blob - python-distutils-extra.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / python-distutils-extra.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         pkgname         distutils-extra
8 %define         module          DistUtilsExtra
9 %define         egg_name        python_distutils_extra
10 Summary:        Python 2 DistUtilsExtra module - i18n, documentation and icons support for distutils
11 Summary(pl.UTF-8):      Moduł Pythona 2 DistUtilsExtra - obsługa i18n, dokumentacji i ikon dla distutils
12 Name:           python-%{pkgname}
13 Version:        2.39
14 Release:        5
15 License:        GPL v2
16 Group:          Libraries/Python
17 Source0:        http://launchpad.net/python-distutils-extra/trunk/%{version}/+download/%{name}-%{version}.tar.gz
18 # Source0-md5:  16e06db0ef73a35b4bff4b9eed5699b5
19 URL:            http://www.glatzor.de/projects/python-distutils-extra/
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 %if %{with python2}
23 BuildRequires:  python-devel >= 1:2.5
24 BuildRequires:  python-modules >= 1:2.5
25 BuildRequires:  python-setuptools
26 %endif
27 %if %{with python3}
28 BuildRequires:  python3-devel >= 1:3.2
29 BuildRequires:  python3-modules >= 1:3.2
30 BuildRequires:  python3-setuptools
31 %endif
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Python-distutils-extra allows to easily integrate themable icons,
37 scrollkeeper based documentation and gettext based translations in
38 your Python install and build tools. It can be used with Python's
39 distutils or the enhanced setuptools.
40
41 %description -l pl.UTF-8
42 Ten pakiet pozwala łatwo zintegrować ikony z obsługą motywów,
43 dokumentacje opartą na scrollkeeperze i tłumaczenia oparte na
44 gettekście w tworzonych narzędziach do budowania i instalacji pakietów
45 pythonowych. Może być używany z pythonowymi distutils lub
46 rozszerzonymi setuptools.
47
48 %package -n python3-%{pkgname}
49 Summary:        Python 3 DistUtilsExtra module - i18n, documentation and icons support for distutils
50 Summary(pl.UTF-8):      Moduł Pythona 3 DistUtilsExtra - obsługa i18n, dokumentacji i ikon dla distutils
51 Group:          Libraries/Python
52
53 %description -n python3-%{pkgname}
54 Python-distutils-extra allows to easily integrate themable icons,
55 scrollkeeper based documentation and gettext based translations in
56 your Python install and build tools. It can be used with Python's
57 distutils or the enhanced setuptools.
58
59 %description -n python3-%{pkgname} -l pl.UTF-8
60 Ten pakiet pozwala łatwo zintegrować ikony z obsługą motywów,
61 dokumentacje opartą na scrollkeeperze i tłumaczenia oparte na
62 gettekście w tworzonych narzędziach do budowania i instalacji pakietów
63 pythonowych. Może być używany z pythonowymi distutils lub
64 rozszerzonymi setuptools.
65
66 %prep
67 %setup -q
68
69 %build
70 %if %{with python2}
71 %py_build %{?with_tests:test}
72 %endif
73
74 %if %{with python3}
75 %py3_build %{?with_tests:test}
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %if %{with python2}
81 %py_install
82 %py_postclean
83 %endif
84
85 %if %{with python3}
86 %py3_install
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %if %{with python2}
93 %files
94 %defattr(644,root,root,755)
95 %{py_sitescriptdir}/%{module}
96 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
97 %endif
98
99 %if %{with python3}
100 %files -n python3-%{pkgname}
101 %defattr(644,root,root,755)
102 %{py3_sitescriptdir}/%{module}
103 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
104 %endif
This page took 0.966036 seconds and 3 git commands to generate.