]> git.pld-linux.org Git - SPECS.git/blob - python-decompyle.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / python-decompyle.spec
1 %define         module  decompyle
2 #
3 Summary:        Python 1.5 Decompiler
4 Name:           python-%{module}
5 Version:        2.3.2
6 Release:        1
7 License:        BSD-like
8 Group:          Development/Languages/Python
9 Source0:        http://downloads.sourceforge.net/decompyle/decompyle_%{version}.tar.gz
10 # Source0-md5:  6d715feebf748fb0da3b8c1f705584b3
11 Patch0:         %{name}-hack.patch
12 URL:            http://sourceforge.net/projects/decompyle/
13 BuildRequires:  python-devel
14 BuildRequires:  rpmbuild(macros) >= 1.710
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Decompyle is a Python 1.5 disassembler and decompiler which converts
19 Python 1.5 byte-code (.pyc or .pyo) back into equivalent Python
20 source. Verification of the produced code (re-compiled) is avaliable
21 as well.
22
23 %prep
24 %setup -q -n %{module}-%{version}.orig
25 %patch0 -p1
26
27 %build
28 %py_build
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32
33 %py_install
34
35 %py_postclean
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc ANNOUNCE CHANGES README TODO
43 %attr(755,root,root) %{_bindir}/decompyle
44 %dir %{py_sitedir}/decompyle
45 %{py_sitedir}/decompyle/*.py*
46 %{py_sitedir}/decompyle-*.egg-info
47 %attr(755,root,root) %{py_sitedir}/decompyle/marshal_*.so
This page took 0.783185 seconds and 3 git commands to generate.