]> git.pld-linux.org Git - SPECS.git/blob - python-ctypes.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / python-ctypes.spec
1 #
2 # TODO:
3 # - move the scripts from the wrap subpackage to /usr/bin?
4 %define         module ctypes
5
6 Summary:        Python package to call functions in dynamic linked libraries
7 Summary(pl.UTF-8):      Pakiet Pythona do wywoływania funkcji w bibliotekach linkowanych dynamicznie
8 Name:           python-%{module}
9 Version:        1.0.2
10 Release:        1
11 License:        MIT
12 Group:          Development/Languages/Python
13 Source0:        http://dl.sourceforge.net/ctypes/%{module}-%{version}.tar.gz
14 # Source0-md5:  94ff7aa7f7f71b23bac8a98065d77743
15 URL:            http://starship.python.net/crew/theller/ctypes/
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 # modified libffi included
18 #BuildRequires: libffi-devel
19 BuildRequires:  python-devel >= 2.3
20 BuildRequires:  python-modules >= 2.3
21 # ctypes already included in python 2.5
22 BuildRequires:  python < 1:2.5
23 BuildRequires:  rpm-pythonprov
24 %pyrequires_eq  python-libs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 ctypes is a Python package to create and manipulate C data types in
29 Python, and to call functions in dynamic link libraries/shared dlls.
30 It allows wrapping these libraries in pure Python.
31
32 %description -l pl.UTF-8
33 ctypes to pakiet Pythona do tworzenia i obróbki typów danych z C w
34 Pythonie oraz wywoływania funkcji z dynamicznie linkowanych i
35 współdzielonych bibliotek. Umożliwia obudowywanie tych bibliotek w
36 czystym Pythonie.
37
38 %prep
39 %setup -q -n %{module}-%{version}
40
41 %build
42 %py_build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %py_install
48
49 %py_postclean
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.txt docs/
57 %{py_sitedir}/ctypes
58 %attr(755,root,root) %{py_sitedir}/_ctypes.so
59 %attr(755,root,root) %{py_sitedir}/_ctypes_test.so
This page took 0.706431 seconds and 3 git commands to generate.