]> git.pld-linux.org Git - SPECS.git/blob - python-cryptkit.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / python-cryptkit.spec
1 %define         module  cryptkit
2 Summary:        Small, fast cryptographic toolkit for python
3 Summary(pl.UTF-8):      Mały i szybki zbiór narzędzi kryptograficznych dla pythona
4 Name:           python-%{module}
5 Version:        0.9
6 Release:        1
7 License:        BSD
8 Group:          Development/Languages/Python
9 Source0:        http://dl.sourceforge.net/project/cryptkit/_cryptkit/Complete%20Kit/cryptkit-%{version}.tar.gz
10 # Source0-md5:  77e4693a153c31170e9ef6f4e29819ff
11 URL:            http://sourceforge.net/projects/cryptkit/
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 # if py_postclean is used
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 #Requires:              python-libs
17 Requires:       python-modules
18 # BuildArch:    noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 CryptKit is a small, fast cryptographic toolkit for python. It
23 implements Rijndael(AES), SHA 256, Elliptic Curve PKI, Diffie-Hellman
24 key exchange and Nyberg-Ruppel signature/verification. Comprehensive
25 enough to provide a secure socket alternative to SSL
26
27 %description -l pl.UTF-8
28 CryptKit to mały, szybki zbiór narzędzi kryptograficznych dla
29 pythona. Implementuje Rijndael(AES), SHA 256, kryptografię krzywych
30 eliptycznych, wymianę kluczy Diffie-Hellman i sytem Nyberg-Ruppel.
31 Wystarczająco jasny aby być alternatywą dla SSL.
32
33 %prep
34 %setup -q -n %{module}-%{version}
35
36 %build
37 %py_build
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 %py_install
42
43 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
44 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
45 %py_postclean
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 #%doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
53 # %{py_sitedir}/*.py[co]
54 # %{py_sitescriptdir}/%{module}
55 %attr(755,root,root) %{py_sitedir}/*.so
56 %{py_sitedir}/aes
57 %{py_sitedir}/cryptsock
58 %{py_sitedir}/ecc
59 %{py_sitedir}/entropy
60 %{py_sitedir}/sha256
61 %if "%{py_ver}" > "2.4"
62 %{py_sitedir}/TEMPLATE-*.egg-info
63 %endif
This page took 0.282749 seconds and 3 git commands to generate.