]> git.pld-linux.org Git - SPECS.git/blob - python-coverage-test-runner.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-coverage-test-runner.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define module coverage-test-runner
6 Summary:        Python module for enforcing code coverage completeness
7 Name:           python-%{module}
8 Version:        1.11
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries/Python
12 Source0:        http://code.liw.fi/debian/pool/main/p/python-coverage-test-runner/%{name}_%{version}.orig.tar.xz
13 # Source0-md5:  74dde92363a7fcc0dabe840e9e662857
14 URL:            http://liw.fi/coverage-test-runner/
15 BuildRequires:  python-coverage
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.710
18 Requires:       python-coverage
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 CoverageTestRunner is a Python module for running unit tests and
24 failing them if the unit test module does not exercise all statements
25 in the module it tests.
26
27 For example, unit tests in module foo_tests.py are supposed to test
28 everything in the foo.py module, and if they don't, it's a bug in the
29 test coverage. It does not matter if other tests happen to test the
30 missing parts. The unit tests for the module should test everything in
31 that module.
32
33 %prep
34 %setup -q
35
36 %build
37 %py_build
38
39 %if %{with tests}
40 %{__make} check
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 %py_install
46
47 %py_postclean
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc NEWS README
55 %{py_sitescriptdir}/CoverageTestRunner.py[co]
56 %{py_sitescriptdir}/CoverageTestRunner-%{version}-py*.egg-info
This page took 0.207229 seconds and 3 git commands to generate.