]> git.pld-linux.org Git - SPECS.git/blob - python-constantly.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-constantly.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Symbolic constants in Python 2
7 Summary(pl.UTF-8):      Stałe symboliczne w Pythonie 2
8 Name:           python-constantly
9 Version:        15.1.0
10 Release:        2
11 License:        MIT
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.org/simple/constantly/
14 Source0:        https://files.pythonhosted.org/packages/source/c/constantly/constantly-%{version}.tar.gz
15 # Source0-md5:  f0762f083d83039758e53f8cf0086eef
16 URL:            https://pypi.org/project/constantly/
17 %if %{with python2}
18 BuildRequires:  python-modules >= 1:2.7
19 BuildRequires:  python-setuptools
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-modules >= 1:3.3
23 BuildRequires:  python3-setuptools
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.714
27 Requires:       python-modules >= 1:2.7
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A library that provides symbolic constant support. It includes
33 collections and constants with text, numeric, and bit flag values.
34 Originally twisted.python.constants from the Twisted project.
35
36 %description -l pl.UTF-8
37 Biblioteka zapewniająca obsługę stałych symbolicznych. Obejmuje
38 kolekcje i stałe o wartościch tekstowych, numerycznych i flagach
39 bitowych. Wywodzi się z modułu twisted.python.constant z projektu
40 Twisted.
41
42 %package -n python3-constantly
43 Summary:        Symbolic constants in Python 3
44 Summary(pl.UTF-8):      Stałe symboliczne w Pythonie 3
45 Group:          Libraries/Python
46 Requires:       python3-modules >= 1:3.3
47
48 %description -n python3-constantly
49 A library that provides symbolic constant support. It includes
50 collections and constants with text, numeric, and bit flag values.
51 Originally twisted.python.constants from the Twisted project.
52
53 %description -n python3-constantly -l pl.UTF-8
54 Biblioteka zapewniająca obsługę stałych symbolicznych. Obejmuje
55 kolekcje i stałe o wartościch tekstowych, numerycznych i flagach
56 bitowych. Wywodzi się z modułu twisted.python.constant z projektu
57 Twisted.
58
59 %prep
60 %setup -q -n constantly-%{version}
61
62 %build
63 %if %{with python2}
64 %py_build
65 %endif
66
67 %if %{with python3}
68 %py3_build
69 %endif
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %if %{with python2}
75 %py_install
76
77 %py_postclean
78 %endif
79
80 %if %{with python3}
81 %py3_install
82 %endif
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %if %{with python2}
88 %files
89 %defattr(644,root,root,755)
90 %doc CREDITS LICENSE README.rst
91 %{py_sitescriptdir}/constantly
92 %{py_sitescriptdir}/constantly-%{version}-py*.egg-info
93 %endif
94
95 %if %{with python3}
96 %files -n python3-constantly
97 %defattr(644,root,root,755)
98 %doc CREDITS LICENSE README.rst
99 %{py3_sitescriptdir}/constantly
100 %{py3_sitescriptdir}/constantly-%{version}-py*.egg-info
101 %endif
This page took 0.559446 seconds and 3 git commands to generate.