]> git.pld-linux.org Git - SPECS.git/blob - python-async.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / python-async.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_with     python3 # CPython 3.x module [broken: async is a keyword in python 3.5+]
5 %bcond_without  tests   # unit tests
6
7 %define         module  async
8 Summary:        Async Framework
9 Summary(pl.UTF-8):      Szkielet Async do programowania asynchronicznego
10 Name:           python-%{module}
11 Version:        0.6.2
12 Release:        2
13 License:        BSD
14 Group:          Development/Languages/Python
15 #Source0Download: https://pypi.org/simple/async/
16 Source0:        https://files.pythonhosted.org/packages/source/a/async/%{module}-%{version}.tar.gz
17 # Source0-md5:  9b06b5997de2154f3bc0273f80bcef6b
18 URL:            https://github.com/gitpython-developers/async
19 %if %{with python}
20 BuildRequires:  python-devel >= 1:2.6
21 BuildRequires:  python-setuptools
22 %{?with_tests:BuildRequires:    python-nose}
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-devel >= 1:3.3
26 BuildRequires:  python3-devel < 1:3.5
27 BuildRequires:  python3-setuptools
28 %{?with_tests:BuildRequires:    python3-nose}
29 %endif
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.714
32 Requires:       python-modules >= 1:2.6
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Async is a framework to process interdependent tasks in a pool of
38 workers.
39
40 %description -l pl.UTF-8
41 Async to szkielet do przetwarzania niezależnych zadań przez pulę
42 workerów.
43
44 %package -n python3-%{module}
45 Summary:        Async Framework
46 Summary(pl.UTF-8):      Szkielet Async do programowania asynchronicznego
47 Group:          Development/Languages/Python
48 Requires:       python3-modules >= 1:3.3
49
50 %description -n python3-%{module}
51 Async is a framework to process interdependent tasks in a pool of
52 workers.
53
54 %description -n python3-%{module} -l pl.UTF-8
55 Async to szkielet do przetwarzania niezależnych zadań przez pulę
56 workerów.
57
58 %prep
59 %setup -q -n %{module}-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build %{?with_tests:test}
64 %endif
65
66 %if %{with python3}
67 %py3_build %{?with_tests:test}
68 %endif
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %if %{with python2}
74 %py_install
75
76 %py_postclean
77
78 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/async/test
79 %endif
80
81 %if %{with python3}
82 %py3_install
83
84 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/async/test
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS LICENSE
94 %dir %{py_sitescriptdir}/async
95 %{py_sitescriptdir}/async/*.py[co]
96 %{py_sitescriptdir}/async-%{version}-py*.egg-info
97 %endif
98
99 %if %{with python3}
100 %files -n python3-%{module}
101 %defattr(644,root,root,755)
102 %doc AUTHORS LICENSE
103 %dir %{py3_sitescriptdir}/async
104 %{py3_sitescriptdir}/async/*.py
105 %{py3_sitescriptdir}/async/__pycache__
106 %{py3_sitescriptdir}/async-%{version}-py*.egg-info
107 %endif
This page took 0.390662 seconds and 3 git commands to generate.