]> git.pld-linux.org Git - SPECS.git/blob - pulseaudio-dlna.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / pulseaudio-dlna.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         module          pulseaudio_dlna
6 %define         egg_name        pulseaudio_dlna
7 Summary:        A small DLNA server which brings DLNA / UPNP supportto PulseAudio and Linux
8 Name:           pulseaudio-dlna
9 Version:        0.5.2
10 Release:        1
11 License:        GPL v3
12 Group:          Applications/Sound
13 Source0:        https://github.com/masmu/pulseaudio-dlna/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  3773d0333b9fc722878462e550a06a24
15 URL:            https://github.com/masmu/pulseaudio-dlna
16 BuildRequires:  python-chardet >= 2.0.1
17 BuildRequires:  python-docopt >= 0.6.1
18 BuildRequires:  python-futures >= 2.1.6
19 BuildRequires:  python-lxml >= 3
20 BuildRequires:  python-modules
21 BuildRequires:  python-netifaces >= 0.8
22 BuildRequires:  python-notify2 >= 0.3
23 BuildRequires:  python-protobuf >= 2.5.0
24 BuildRequires:  python-psutil >= 1.2.1
25 BuildRequires:  python-requests >= 2.2.1
26 BuildRequires:  python-setproctitle >= 1.0.1
27 BuildRequires:  python-setuptools
28 BuildRequires:  python-zeroconf >= 0.17
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.714
31 Requires:       sox
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A small DLNA server which brings DLNA / UPNP support to PulseAudio and
37 Linux.
38
39 It can stream your current PulseAudio playback to different UPNP
40 devices (UPNP Media Renderers) in your network. It's main goals are:
41 easy to use, no configuration hassle, no big dependencies. Renderers
42 in your network will show up as pulseaudio sinks.
43
44 By default this only pulls sox for basic transcoding. Optionally you
45 can install vorbis-tools, faac, flac, lame, opus-tools, ffmpeg for
46 better performance or quality. Check the man page for instructions and
47 how to use different encoders.
48
49 %prep
50 %setup -q
51
52 %build
53 %py_build %{?with_tests:test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %py_install
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README.md
65 %attr(755,root,root) %{_bindir}/pulseaudio-dlna
66 %{_mandir}/man1/pulseaudio-dlna.1*
67 %{py_sitescriptdir}/%{module}
68 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
This page took 0.120873 seconds and 3 git commands to generate.