]> git.pld-linux.org Git - SPECS.git/blob - portsentry.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / portsentry.spec
1 Summary:        Port scan detection and active defense
2 Summary(pl.UTF-8):      Program wykrywający skanowanie portów i umożliwiający obronę
3 Name:           portsentry
4 Version:        1.1
5 Release:        11
6 License:        distributable (see LICENSE)
7 Group:          Applications/Networking
8 Source0:        http://www.psionic.com/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  782839446b7eca554bb1880ef0882670
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-logging-pld.patch
13 Patch1:         %{name}-ignore.csh.patch
14 Patch2:         %{name}-libwrap.patch
15 Patch3:         %{name}-config.patch
16 URL:            http://www.psionic.com/products/
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(post,preun):   fileutils
20 Requires:       awk
21 Requires:       iproute2
22 Requires:       rc-scripts
23 Requires:       textutils
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/portsentry
27
28 %description
29 PortSentry is part of the Abacus Project suite of tools. The Abacus
30 Project is an initiative to release low-maintenance, generic, and
31 reliable host based intrusion detection software to the Internet
32 community.
33
34 %description -l pl.UTF-8
35 PortSentry jest częścią zestawu narzędzi Projektu Abacus. Projekt
36 Abacus ma na celu stworzenie ogólnego, pewnego i wymagającego
37 niewielkiej obsługi oprogramowania do wykrywania prób skanowania
38 portów dla internetowej społeczności.
39
40 %prep
41 %setup  -q
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3 -p1
46
47 %build
48 %{__make} linux \
49         CC="%{__cc}" \
50         CFLAGS="%{rpmcflags} -Wall"
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT{%{_sbindir},/etc/{rc.d/init.d,sysconfig}}
55
56 %{__make} install \
57         INSTALLDIR=$RPM_BUILD_ROOT/etc
58
59 install ignore.csh $RPM_BUILD_ROOT%{_sbindir}/portsentry-ignore
60 install portsentry $RPM_BUILD_ROOT%{_sbindir}
61
62 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/portsentry
63 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/portsentry
64
65 touch $RPM_BUILD_ROOT%{_sysconfdir}/{portsentry.blocked.{audp,atcp,stcp,sudp,tcp,udp},portsentry.history}
66
67 # the portsentry binary
68 rm -f $RPM_BUILD_ROOT/etc/portsentry/portsentry
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 %{_sbindir}/portsentry-ignore
75 /sbin/chkconfig --add portsentry
76 %service portsentry restart "portsentry daemon"
77
78 %preun
79 if [ "$1" = "0" ]; then
80         %service portsentry stop
81         /sbin/chkconfig --del portsentry
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README* CHANGES CREDITS LICENSE
87 %attr(750,root,root) %dir %{_sysconfdir}
88 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/portsentry.conf
89 %attr(640,root,root) %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/portsentry.ignore
90 %attr(640,root,root) %ghost %{_sysconfdir}/portsentry.history
91 %attr(640,root,root) %ghost %{_sysconfdir}/portsentry.blocked*
92 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
93 %attr(754,root,root) /etc/rc.d/init.d/*
94 %attr(755,root,root) %{_sbindir}/*
This page took 0.291406 seconds and 3 git commands to generate.