]> git.pld-linux.org Git - SPECS.git/blob - poker3d.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / poker3d.spec
1 #TODO:
2 # - summary, description
3 # - check python
4 # - check files 
5 # - make it work
6 # - server init scripts
7 # - user and group for server ?
8 # - french translation (debian patch)
9 # - teoretically underware is a library to create games, not necesary
10 #   poker, but it links to libpoker-eval
11
12 Summary:        Multiuser 3D online poker game
13 Summary(pl.UTF-8):      Sieciowa gra w pokera w 3D
14 Name:           poker3d
15 Version:        0.2.12
16 Release:        0.1
17 License:        GPL v2
18 Group:          X11/Applications/Games
19 Source0:        http://download.gna.org/underware/dists/%{name}-%{version}.tar.gz
20 # Source0-md5:  e4a16c02f5abb4bf6c5c30a366ab0cf9
21 Patch0:         %{name}-cal3d.patch
22 Patch1:         %{name}-namespace.patch
23 URL:            http://www.mekensleep.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  OpenSceneGraph-devel >= 0.9.7
26 BuildRequires:  SDL-devel >= 1.2.0
27 BuildRequires:  autoconf >= 2.54
28 BuildRequires:  automake
29 BuildRequires:  cal3d-devel
30 BuildRequires:  doxygen
31 BuildRequires:  fontconfig-devel
32 BuildRequires:  gettext-autopoint
33 BuildRequires:  libglade2-devel >= 2.4.0
34 BuildRequires:  libvorbis-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel
38 BuildRequires:  osgAL-devel
39 BuildRequires:  osgcal-devel >= 0.1.23
40 BuildRequires:  poker-eval-devel >= 123.0
41 BuildRequires:  python-devel >= 2.3
42 Requires:       %{name}-common = %{version}-%{release}
43 Requires:       Xwnc
44 Requires:       python-pycurl
45 %pyrequires_eq  python-libs
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Poker3D is a multiuser online poker game. It connects to server where
50 thirteen tables can be found (Hold'em, Omaha, Omaha8, 7 Stud, Sit and
51 Go tournaments) with more than fifty players.
52
53 %description -l pl.UTF-8
54 Poker3D jest wieloosobową grą sieciową w pokera. Łączy się z serwerem
55 gdzie można znaleźć do trzynastu stołów (turnieje Hold'em, Omaha,
56 Omaha8, 7 Stud, Sit and Go) z ponad pięćdziesięcioma graczami.
57
58 %package common
59 Summary:        Common files for game and server
60 Summary(pl.UTF-8):      Wspólne pliki serwera i gry
61 Group:          Applications/Games
62 Requires:       underware = %{version}-%{release}
63 Requires:       pypoker-eval
64 Requires:       python-Twisted
65 Requires:       python-libxml2
66
67 %description common
68 Poker3D - common files.
69
70 %description common -l pl.UTF-8
71 Poker3D - pliki współdzielone.
72
73 %package server
74 Summary:        Poker3D server
75 Summary(pl.UTF-8):      Serwer trójwymiarowego pokera
76 Group:          Applications/Games
77 Requires:       poker3d-common = %{version}-%{release}
78 Requires:       python-MySQLdb
79
80 %description server
81 This is Poker3D server.
82
83 %description server -l pl.UTF-8
84 To jest serwer gry Poker3D.
85
86 %package -n underware
87 Summary:        underware - 3D game programming libraries
88 Summary(pl.UTF-8):      underware - biblioteki programistyczne gier trójwymiarowych
89 Group:          Libraries
90
91 %description -n underware
92 underware - 3D game programming libraries.
93
94 %description -n underware -l pl.UTF-8
95 underware - biblioteki programistyczne gier trójwymiarowych.
96
97 %package -n underware-devel
98 Summary:        underware header files
99 Summary(pl.UTF-8):      Pliki nagłówkowe underware
100 Group:          Development/Libraries
101 Requires:       underware = %{version}-%{release}
102 Requires:       OpenSceneGraph-devel
103 Requires:       cal3d-devel
104 Requires:       libstdc++-devel
105 Requires:       osgAL-devel
106 Requires:       osgcal-devel
107
108 %description -n underware-devel
109 This package contains underware header files.
110
111 %description -n underware-devel -l pl.UTF-8
112 Ten pakiet zawiera pliki nagłówkowe underware.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117 %patch1 -p1
118
119 %build
120 %{__autopoint}
121 %{__libtoolize}
122 %{__aclocal} -I config
123 %{__autoconf}
124 %{__autoheader}
125 %{__automake}
126 %configure \
127         --disable-static
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135 find $RPM_BUILD_ROOT -name "*.py" -and -not -name "jabberaccount.py" \
136         -exec rm "{}" ";"
137
138 rm -f $RPM_BUILD_ROOT%{py_sitedir}/underware/*.la
139
140 # empty
141 # %find_lang underware
142 touch underware.lang
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   common  -p /sbin/ldconfig
148 %postun common  -p /sbin/ldconfig
149
150 %post   -n underware    -p /sbin/ldconfig
151 %postun -n underware    -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/poker3d
156 %attr(755,root,root) %{_bindir}/poker3d-interface
157 %{_mandir}/man6/poker3d.6*
158 %{_mandir}/man6/poker3d-interface.6*
159 %{_datadir}/underware/poker/data
160 %{_datadir}/underware/interface.glade*
161 %{_sysconfdir}/poker3d/client
162 %{_sysconfdir}/poker3d/engine
163 %{_sysconfdir}/poker3d/gaim
164
165 %files common
166 %defattr(644,root,root,755)
167 %dir %{_sysconfdir}/poker3d
168 %dir %{_datadir}/underware/poker
169 %{_datadir}/underware/poker/*.py[co]
170 %{_datadir}/underware/twibber
171 %{_datadir}/underware/jabberaccount.py
172 %attr(755,root,root) %{_libdir}/libpoker.so.*.*.*
173
174 %files server
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/poker3d-server
177 %{_mandir}/man6/poker3d-server.6*
178 %{_sysconfdir}/poker3d/tournament
179 %{_sysconfdir}/poker3d/server
180 %{_sysconfdir}/poker3d/bot
181 %{_datadir}/underware/poker/db
182
183 %files -n underware -f underware.lang
184 %defattr(644,root,root,755)
185 %doc AUTHORS ChangeLog CREDITS LICENSE.OSG LICENSE.twibber NEWS README
186 %attr(755,root,root) %{_bindir}/underware
187 %dir %{_datadir}/underware
188 %attr(755,root,root) %{_libdir}/lib[emu]*.so.*.*.*
189 %{_mandir}/man6/underware.6*
190 %dir %{py_sitedir}/underware
191 %{py_sitedir}/underware/*.py[co]
192 %attr(755,root,root) %{py_sitedir}/underware/*.so*
193 %attr(755,root,root) %{_libdir}/osgPlugins/libosgdb_hdr.so.*.*.*
194
195 %files -n underware-devel
196 %defattr(644,root,root,755)
197 %{_includedir}/underware
198 %attr(755,root,root) %{_libdir}/lib[emu]*.so
199 %{_libdir}/lib[emu]*.la
200 %{_pkgconfigdir}/underware.pc
201 %attr(755,root,root) %{_libdir}/osgPlugins/libosgdb_hdr.so
202 # XXX: check if needed
203 %{_libdir}/osgPlugins/libosgdb_hdr.la
This page took 0.036792 seconds and 3 git commands to generate.