]> git.pld-linux.org Git - SPECS.git/blob - ploop.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / ploop.spec
1 Summary:        Tools for ploop devices and images
2 Summary(pl.UTF-8):      Narzędzia do urządzeń i obrazów ploop
3 Name:           ploop
4 Version:        8.0.14
5 Release:        2
6 License:        GPL v2+
7 Group:          Applications/System
8 #Source0Download: https://github.com/OpenVZ/ploop/releases
9 Source0:        https://github.com/OpenVZ/ploop/archive/v%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  76bc12dd67ed9201d02bc156fbb6a17a
11 Patch0:         %{name}-types.patch
12 Patch1:         %{name}-python.patch
13 Patch2:         %{name}-gcc.patch
14 URL:            https://wiki.openvz.org/Ploop
15 BuildRequires:  libxml2-devel >= 2.0
16 BuildRequires:  python3-devel >= 1:3.2
17 BuildRequires:  rpmbuild(macros) >= 1.673
18 BuildRequires:  sed >= 4.0
19 Requires:       %{name}-libs = %{version}-%{release}
20 Requires:       /sbin/modprobe
21 Requires:       awk
22 Requires:       parted
23 Requires:       sed
24 Requires:       udev-core >= 1:182-6
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This package contains tools to work with ploop devices and images.
29
30 %description -l pl.UTF-8
31 Ten pakiet zawiera narzędzia do pracy z urządzeniami o obrazami ploop.
32
33 %package -n bash-completion-ploop
34 Summary:        Bash completion for ploop commands
35 Summary(pl.UTF-8):      Bashowe dopełnianie składni poleceń ploop
36 Group:          Applications/Shells
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       bash-completion >= 2.0
39
40 %description -n bash-completion-ploop
41 Bash completion for ploop commands.
42
43 %description -n bash-completion-ploop -l pl.UTF-8
44 Bashowe dopełnianie składni poleceń ploop.
45
46 %package libs
47 Summary:        ploop library
48 Summary(pl.UTF-8):      Biblioteka ploop
49 Group:          Libraries
50 Obsoletes:      ploop-lib
51
52 %description libs
53 Parallels loopback (ploop) block device API library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka do obsługi urządzeń blokowych ploop (Parallels loopback).
57
58 %package devel
59 Summary:        Header files for ploop library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ploop
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63
64 %description devel
65 Header files for ploop library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki ploop.
69
70 %package static
71 Summary:        Static ploop library
72 Summary(pl.UTF-8):      Biblioteka statyczna ploop
73 Group:          Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static ploop library.
78
79 %description static -l pl.UTF-8
80 Biblioteka statyczna ploop.
81
82 %package -n python3-libploop
83 Summary:        Python 3 interface to ploop library
84 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki ploop
85 Group:          Libraries/Python
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n python3-libploop
89 Python 3 interface to ploop library.
90
91 %description -n python3-libploop -l pl.UTF-8
92 Interfejs Pythona 3 do biblioteki ploop.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99
100 # honour %{_libexecdir} whatever it's set to
101 %{__sed} -i -e '/exe = / s,/usr/libexec,%{_libexecdir},' scripts/crypthelper
102 %{__sed} -i -e '/define CRYPT_BIN/ s,/usr/libexec,%{_libexecdir},' lib/crypt.c
103 # drop /usr/libexec/{tune,resize,dumpe}2fs from tools search
104 %{__sed} -i -e '/\/usr\/libexec\/.*2fs/d' lib/fsutils.c
105
106 %build
107 LDFLAGS="%{rpmldflags}" \
108 LDLIBS="-lpthread" \
109 %{__make} all \
110         V=1 \
111         DEBUG= \
112         CC="%{__cc}" \
113         CPPFLAGS="%{rpmcppflags}" \
114         RPM_OPT_FLAGS="%{rpmcflags}" \
115         LIBDIR=%{_libdir}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         V=1 \
122         INSTALL="install -p" \
123         COMPLETIONDIR=%{bash_compdir} \
124         LIBDIR=%{_libdir} \
125         LIBSCRIPTDIR=%{_libexecdir}/ploop \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} $RPM_BUILD_ROOT%{_sbindir}/ploop-test
129 %{__rm} -r $RPM_BUILD_ROOT/usr/libexec/ploop-test
130
131 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
132 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc tools/README
143 %attr(755,root,root) /sbin/mount.ploop
144 %attr(755,root,root) /sbin/umount.ploop
145 %attr(755,root,root) %{_sbindir}/ploop
146 %attr(755,root,root) %{_sbindir}/ploop-balloon
147 %attr(755,root,root) %{_sbindir}/ploop-cbt
148 %attr(755,root,root) %{_sbindir}/ploop-volume
149 %dir %{_libexecdir}/ploop
150 %attr(755,root,root) %{_libexecdir}/ploop/crypthelper
151 /etc/modules-load.d/ploop.conf
152 %dir /var/lock/ploop
153 %{systemdtmpfilesdir}/ploop.conf
154 %{_mandir}/man8/ploop.8*
155
156 %files -n bash-completion-ploop
157 %defattr(644,root,root,755)
158 %{bash_compdir}/ploop
159
160 %files libs
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libploop.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libploop.so.8
164 %dir /var/lock/ploop
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libploop.so
169 %{_includedir}/ploop
170 %{_pkgconfigdir}/ploop.pc
171
172 %files static
173 %defattr(644,root,root,755)
174 %{_libdir}/libploop.a
175
176 %files -n python3-libploop
177 %defattr(644,root,root,755)
178 %dir %{py3_sitedir}/libploop
179 %attr(755,root,root) %{py3_sitedir}/libploop/libploopapi.cpython-*.so
180 %{py3_sitedir}/libploop/__init__.py
181 %{py3_sitedir}/libploop/__pycache__
182 %{py3_sitedir}/libploop-0.0.0-py*.egg-info
This page took 1.049539 seconds and 3 git commands to generate.