]> git.pld-linux.org Git - SPECS.git/blob - php4-pecl-pop3.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / php4-pecl-pop3.spec
1 %define         _modname        pop3
2 %define         _status         stable
3 %define         _sysconfdir     /etc/php4
4 %define         extensionsdir   %{_libdir}/php4
5 Summary:        POP3 Client Library
6 Summary(pl.UTF-8):      Biblioteka klienta POP3
7 Name:           php4-pecl-%{_modname}
8 Version:        1.0.2
9 Release:        4
10 License:        PHP
11 Group:          Development/Languages/PHP
12 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
13 # Source0-md5:  cdbe4f41aa37bcf45e651d5568f3a8d2
14 URL:            http://pecl.php.net/package/POP3/
15 BuildRequires:  libspopc-devel
16 BuildRequires:  php4-devel >= 3:4.3.0
17 BuildRequires:  rpmbuild(macros) >= 1.344
18 %{?requires_php_extension}
19 Requires:       php4-common >= 3:4.4.0-3
20 Obsoletes:      php-pear-%{_modname}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The POP3 extension makes it possible for a PHP script to connect to
25 and interact with a POP3 mail server. Based on libspopc
26 (http://brouits.free.fr/libspopc/), it is built for performance and
27 ease of use.
28
29 In PECL status of this package is: %{_status}.
30
31 %description -l pl.UTF-8
32 Rozszerzenie POP3 umożliwia skryptowi PHP podłączenie i współpracę z
33 serwerem POP3. Biblioteka bazująca na libspopc
34 (http://brouits.free.fr/libspopc/), stworzona została z myślą o
35 wydajności i łatwości użycia.
36
37 To rozszerzenie ma w PECL status: %{_status}.
38
39 %prep
40 %setup -q -c
41
42 %build
43 cd %{_modname}-%{version}
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/conf.d,%{extensionsdir}}
51
52 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
53 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/%{_modname}.ini
54 ; Enable %{_modname} extension module
55 extension=%{_modname}.so
56 EOF
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
63 [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
64
65 %postun
66 if [ "$1" = 0 ]; then
67         [ ! -f /etc/apache/conf.d/??_mod_php4.conf ] || %service -q apache restart
68         [ ! -f /etc/httpd/httpd.conf/??_mod_php4.conf ] || %service -q httpd restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
74 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/%{_modname}.ini
75 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.103705 seconds and 3 git commands to generate.