]> git.pld-linux.org Git - SPECS.git/blob - php4-dbg.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / php4-dbg.spec
1 #
2 # INFO: How to get working: patching, installation, using with PHPeclipse (*very* helpful):
3 #       http://www.phpeclipse.de/tiki-view_forum_thread.php?forumId=3&comments_parentId=3265
4 #
5 Summary:        dbg - PHP debbuger - extension for PHP 4
6 Summary(pl.UTF-8):      dbg - debugger dla PHP - rozszerzenie PHP 4
7 Name:           php4-dbg
8 Version:        2.11.32
9 Release:        0.2
10 License:        The DBG License Version 3.0
11 Group:          Development/Languages/PHP
12 Source0:        http://dl.sourceforge.net/dbg2/dbg-%{version}-src.tar.gz
13 # Source0-md5:  1ac7372bfcb4c5e13cad1248e071d70c
14 Source1:        dbg.ini
15 URL:            http://dd.cron.ru/dbg/
16 BuildRequires:  rpmbuild(macros) >= 1.344
17 BuildRequires:  php4-devel >= 3:4.0.0
18 %{?requires_php_extension}
19 Requires:       php4-common >= 3:4.4.0-3
20 Obsoletes:      dbg
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 DBG is a a full-featured php debugger, an interactive tool that helps
25 you debugging php scripts. It works on a production and/or development
26 WEB server and allows you debug your scripts locally or remotely, from
27 an IDE or console. This package contain dbg extension for PHP 4.
28
29 %description -l pl.UTF-8
30 DBG to w pełni funkcjonalny debugger dla PHP - interaktywne narzędzie
31 pomagające przy diagnostyce skryptów w PHP. Działa zarówno na
32 produkcyjnym jak i rozwojowym serwerze WWW, pozwala na śledzenie
33 skryptów lokalnie jak i zdalnie, z poziomu IDE lub konsoli. Ten pakiet
34 zawiera rozszerzenie dbg dla PHP 4.
35
36 %prep
37 %setup -q -n dbg-%{version}
38
39 %build
40 phpize
41 %configure \
42         --with-dbg-profiler \
43         --enable-dbg=shared
44
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         INSTALL_ROOT=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
54 install %{SOURCE1} $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/dbg.ini
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php4_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php4_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 # don't remove COPYING and INSTALL
70 %doc AUTHORS COPYING INSTALL
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/dbg.ini
72 %attr(755,root,root) %{php_extensiondir}/dbg.so
This page took 0.292989 seconds and 3 git commands to generate.