]> git.pld-linux.org Git - SPECS.git/blob - php-urbanairship.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / php-urbanairship.spec
1 %define         php_min_version  5.2.6
2 %define         pkgname urbanairship
3 Summary:        Urban Airship PHP library - web service API for iPhone push notifications
4 Name:           php-%{pkgname}
5 Version:        0.1
6 Release:        1
7 License:        ?
8 Group:          Development/Languages/PHP
9 Source0:        https://github.com/urbanairship/php-library/tarball/master/%{pkgname}-%{version}.tgz
10 # Source0-md5:  4c0f3befc41103e40b86835262180492
11 URL:            https://github.com/urbanairship/php-library
12 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
13 BuildRequires:  rpmbuild(macros) >= 1.461
14 Requires:       php-common >= 4:%{php_min_version}
15 Requires:       php-pear-HTTP_Request
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _appdir                 %{php_data_dir}/%{pkgname}
20
21 %description
22 This here is a PHP library for using the Urban Airship
23 <http://urbanairship.com/> web service API for iPhone push
24 notifications.
25
26 The library handles these parts of the API:
27 - device token registration
28 - basic push
29 - registering and pushing with tags
30 - broadcast
31 - feedback service
32 - device token deactivation (deregistration)
33 - device token listing
34
35 %prep
36 %setup -qc
37 mv urbanairship-php-library-*/* .
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{php_data_dir}
42 cp -p urbanairship.php $RPM_BUILD_ROOT%{php_data_dir}
43 cp -p RESTClient.php $RPM_BUILD_ROOT%{php_data_dir}
44
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46 cp -p sample.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README.md
54 %{php_data_dir}/urbanairship.php
55 %{php_data_dir}/RESTClient.php
56 %{_examplesdir}/%{name}-%{version}
This page took 0.433103 seconds and 3 git commands to generate.