]> git.pld-linux.org Git - SPECS.git/blob - php-symfony2-Serializer.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / php-symfony2-Serializer.spec
1 %define         package Serializer
2 %define         php_min_version 5.3.9
3 Summary:        Symfony2 Serializer Component
4 Name:           php-symfony2-Serializer
5 Version:        2.8.52
6 Release:        1
7 License:        MIT
8 Group:          Development/Languages/PHP
9 Source0:        https://github.com/symfony/%{package}/archive/v%{version}/%{package}-%{version}.tar.gz
10 # Source0-md5:  92fed432082e45c9e43e9041b3508ac7
11 URL:            http://symfony.com/doc/2.7/components/serializer.html
12 BuildRequires:  phpab
13 BuildRequires:  rpmbuild(macros) >= 1.610
14 Requires:       php(core) >= %{php_min_version}
15 Requires:       php(ctype)
16 Requires:       php(dom)
17 Requires:       php(json)
18 Requires:       php(pcre)
19 Requires:       php(simplexml)
20 Requires:       php(spl)
21 Requires:       php(xml)
22 Requires:       php-dirs >= 1.6
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Serializer Component is meant to be used to turn objects into a
28 specific format (XML, JSON, Yaml, ...) and the other way around.
29
30 %prep
31 %setup -q -n serializer-%{version}
32
33 %build
34 phpab -n -e '*/Tests/*' -o autoload.php .
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}
39 cp -a *.php */ $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}
40 rm -r $RPM_BUILD_ROOT%{php_data_dir}/Symfony/Component/%{package}/Tests
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc CHANGELOG.md LICENSE README.md
48 %dir %{php_data_dir}/Symfony/Component/Serializer
49 %{php_data_dir}/Symfony/Component/Serializer/*.php
50 %{php_data_dir}/Symfony/Component/Serializer/Annotation
51 %{php_data_dir}/Symfony/Component/Serializer/Encoder
52 %{php_data_dir}/Symfony/Component/Serializer/Exception
53 %{php_data_dir}/Symfony/Component/Serializer/Mapping
54 %{php_data_dir}/Symfony/Component/Serializer/NameConverter
55 %{php_data_dir}/Symfony/Component/Serializer/Normalizer
This page took 0.137778 seconds and 3 git commands to generate.