]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-uuid.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / php-pecl-uuid.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         uuid
3 %define         status          stable
4 Summary:        %{modname} - UUID support functions
5 Summary(pl.UTF-8):      %{modname} - funkcje obsługujące UUID
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.4
8 Release:        1
9 License:        LGPL
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  1695511daf585fcaf7816a401a6216f6
13 URL:            http://pecl.php.net/package/uuid/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.4
15 BuildRequires:  libuuid-devel
16 BuildRequires:  rpmbuild(macros) >= 1.650
17 %{?requires_php_extension}
18 Provides:       php(%{modname}) = %{version}
19 Obsoletes:      php-pecl-uuid < 1.0.3-5
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This extension provides functions to generate and analyse universally
24 unique identifiers (UUIDs). It depends on external libuuid. This
25 library is available on most linux systems, its source is bundled with
26 ext2fs tools.
27
28 In PECL status of this package is: %{status}.
29
30 %description -l pl.UTF-8
31 To rozszerzenie dostarcza funkcje do generowania i analizy
32 uniwersalnie unikalnych identyfikatorów (ang. UUIDs). Rozszerznie to
33 wymaga zewnętrznej biblioteki libuuid, dostępnej w większości
34 dystrybucji, której źródło jest dostarczane wraz z narzędziami ext2fs.
35
36 To rozszerzenie ma w PECL status: %{status}.
37
38 %prep
39 %setup -qc
40 mv %{modname}-%{version}/* .
41
42 %build
43 phpize
44 %configure
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
50
51 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
52 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
53 ; Enable %{modname} extension module
54 extension=%{modname}.so
55 EOF
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %php_webserver_restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         %php_webserver_restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.055831 seconds and 3 git commands to generate.