]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-id3.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / php-pecl-id3.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname id3
3 %define         status          alpha
4 Summary:        %{modname} - functions to read and write ID3 tags in MP3 files
5 Summary(pl.UTF-8):      %{modname} - funkcje do odczytu i zapisu tagów ID3 w plikach MP3
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.2
8 Release:        8
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  c19445a5b676a7d5b90d5d19affa9ced
13 URL:            http://pecl.php.net/package/id3/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Provides:       php(%{modname}) = %{version}
19 Obsoletes:      php-pear-%{modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 id3 enables to to retrieve and update information from ID3 tags in MP3
24 files. It supports version 1.0 and version 1.1.
25
26 In PECL status of this extension is: %{status}.
27
28 %description -l pl.UTF-8
29 id3 umożliwia odbiór i aktualizację informacji w tagach ID3 w plikach
30 MP3. Wspiera wersję 1.0 oraz 1.1.
31
32 To rozszerzenie ma w PECL status: %{status}.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
46 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
48 ; Enable %{modname} extension module
49 extension=%{modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %doc CREDITS EXPERIMENTAL TODO
66 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
67 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.184571 seconds and 3 git commands to generate.