]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-gnupg.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / php-pecl-gnupg.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname gnupg
3 %define         status          stable
4 Summary:        %{modname} - wrapper around the gpgme library
5 Summary(pl.UTF-8):      %{modname} - wrapper biblioteki gpgme
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.4.0
8 Release:        1
9 License:        BSD, revised
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  2354cb56168d8ea0f643e548e139d013
13 URL:            http://pecl.php.net/package/gnupg/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.4
15 BuildRequires:  gpgme-devel
16 BuildRequires:  re2c
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Requires:       gpgme >= 1.1.4-2
20 Provides:       php(%{modname}) = %{version}
21 Obsoletes:      php-pecl-gnupg < 1.3.3-3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This extension provides methods to interact with gnupg. So you can
26 sign, encrypt, verify directly from PHP.
27
28 In PECL status of this extension is: %{status}.
29
30 %description -l pl.UTF-8
31 To rozszerzenie dostarcza metody współpracy z gnupg. Umożliwia to
32 podpisywanie, szyfrowanie oraz weryfikację danych z poziomu PHP.
33
34 To rozszerzenie ma w PECL status: %{status}.
35
36 %prep
37 %setup -qc
38 mv %{modname}-%{version}/* .
39
40 %build
41 export CFLAGS="%{rpmcflags} -D_FILE_OFFSET_BITS=64"
42 phpize
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
49
50 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
52 ; Enable %{modname} extension module
53 extension=%{modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc EXPERIMENTAL README
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.463436 seconds and 3 git commands to generate.