]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-event.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / php-pecl-event.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname event
3 %define         status          stable
4 Summary:        %{modname} - event scheduling engine
5 Summary(pl.UTF-8):      %{modname} - silnik do planowania zdarzeń
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        2.4.1
8 Release:        1
9 License:        PHP
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  877c364895e8770fc9a211e667a634b6
13 URL:            http://pecl.php.net/package/event/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Obsoletes:      php-pear-%{modname}
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is an extension to efficiently schedule IO, time and signal based
24 events using the best available IO notification mechanism for your
25 system.
26
27 This is a port of libevent to the PHP infrastructure; the API is
28 similar but not identical.
29
30 In PECL status of this extension is: %{status}.
31
32 %description -l pl.UTF-8
33 To rozszerzenie pozwala na efektywne planowanie We/Wy, czasu oraz
34 opartych na sygnałach zdarzeń za pomocą najlepszego dostępnego dla
35 systemu mechanizmu powiadamiania.
36
37 Jest to port biblioteki libevent do infrastruktury PHP; API jest
38 podobne, jednak nie identyczne.
39
40 To rozszerzenie ma w PECL status: %{status}.
41
42 %prep
43 %setup -qc
44 mv %{modname}-%{version}/* .
45
46 %build
47 phpize
48 %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
54
55 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
56 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
57 ; Enable %{modname} extension module
58 extension=%{modname}.so
59 EOF
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post
65 %php_webserver_restart
66
67 %postun
68 if [ "$1" = 0 ]; then
69         %php_webserver_restart
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc CREDITS INSTALL.md README.md
75 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
76 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.695955 seconds and 3 git commands to generate.