]> git.pld-linux.org Git - SPECS.git/blob - php-pecl-big_int.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / php-pecl-big_int.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname big_int
3 %define         status          stable
4 Summary:        %{modname} - set of functions for calculations with arbitrary length integers
5 Summary(pl.UTF-8):      %{modname} - zestaw funkcji do obliczeń z użyciem liczb o dowolnej wielkości
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.0.7
8 Release:        4
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  d858d5bcfd3f789cb1ae8cb8ff09d3e9
13 URL:            http://pecl.php.net/package/big_int/
14 BuildRequires:  %{php_name}-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.650
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 Obsoletes:      php-pear-%{modname}
19 Provides:       php(%{modname}) = %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This package is useful for number theory applications. For example, in
24 two-keys cryptography. See tests/RSA.php in the package for example of
25 implementation of RSA-like cryptoalgorithm.
26
27 Also the package has many bitset functions, which allow to work with
28 arbitrary length bitsets.
29
30 This package is much faster than bundled into PHP BCMath. It
31 implements almost all functions as in GMP extension, but it needn't
32 any additional external libraries.
33
34 In PECL status of this extension is: %{status}.
35
36 %description -l pl.UTF-8
37 Ten pakiet jest przydatny do zastosowań z teorii liczb, na przykład do
38 kryptografii z użyciem dwóch kluczy. Przykładową implementację
39 algorytmu kryptograficznego podobnego do RSA można znaleźć w tym
40 pakiecie w pliku tests/RSA.php.
41
42 Pakiet ma także wiele funkcji operujących na bitach, umożliwiających
43 działanie na zbiorach bitów dowolnej długości.
44
45 Ten pakiet jest dużo szybszy niż wbudowany w PHP BCMath. Implementuje
46 prawie wszystkie funkcje z rozszerzenia GMP, ale nie wymaga żadnych
47 dodatkowych bibliotek zewnętrznych.
48
49 To rozszerzenie ma w PECL status: %{status}.
50
51 %prep
52 %setup -qc
53 mv %{modname}-%{version}/* .
54
55 %build
56 phpize
57 %configure
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
63 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
64 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
65 ; Enable %{modname} extension module
66 extension=%{modname}.so
67 EOF
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %php_webserver_restart
74
75 %postun
76 if [ "$1" = 0 ]; then
77         %php_webserver_restart
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc CREDITS README docs tests
83 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
84 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.225382 seconds and 3 git commands to generate.