]> git.pld-linux.org Git - SPECS.git/blob - php-pear-PHP_UML.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / php-pear-PHP_UML.spec
1 %define         _status         stable
2 %define         _pearname       PHP_UML
3 Summary:        %{_pearname} - produce an UML/XMI representation of the classes and packages found on system
4 Summary(pl.UTF-8):      %{_pearname} - tworzenie struktury UML/XMI klas i pakietów znalezionych w systemie
5 Name:           php-pear-%{_pearname}
6 Version:        1.6.2
7 Release:        1
8 License:        LGPL
9 Group:          Development/Languages/PHP
10 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
11 # Source0-md5:  8ddf2ce2544ffca69e1ea6d0b0f6b2b5
12 URL:            http://pear.php.net/package/PHP_UML/
13 BuildRequires:  php-pear-PEAR >= 1:1.4.0
14 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
15 BuildRequires:  rpmbuild(macros) >= 1.300
16 Requires:       php(spl)
17 Requires:       php(xsl)
18 Requires:       php-pear
19 Requires:       php-pear-Console_CommandLine
20 Obsoletes:      php-pear-PHP_UML-tests
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 PHP_UML is a PHP parser, an XMI generator, as well as a
26 metamodel-driven application. Practically, with PHP_UML, you can feed
27 an UML CASE tool, like Rational Rose or Argouml, with an UML
28 representation of existing PHP source code. This way, you get an
29 instant overview of a given application, with all the usual functions
30 of a software design tool, like class diagrams exportation,
31 refactoring of object-oriented applications, or automatic code
32 generation.
33
34 PHP_UML:
35  - Parses classes, interfaces, inheritance and implementation
36    relations,
37  - Parses properties, class constants, visibility and static
38    attributes,
39  - Parses functions, their parameters, their default values, their
40    types (when stated),
41  - Parses docblock comments : class comments (@package), function
42    comments (@param and @return) and header file comments (@package),
43  - Interprets the PHP namespacing instructions ("namespace" and "use"),
44  - Does automatic type detection, through the default values,
45  - Generates UML in version 1.4, and version 2.1,
46  - Generates logical, component, and deployment views,
47
48 Other UML elements will be available in future releases.
49
50 In PEAR status of this package is: %{_status}.
51
52 %description -l pl.UTF-8
53 PHP_UML to parser PHP, generator XML jak również aplikacja wzorowana
54 na meta-model. Praktycznie rzecz biorąc, za pomocą PHP_UML możliwe
55 jest przekazanie narzędziom UML CASE, takim jak Rational Rose czy
56 Argouml, schematu UML kodu PHP. W ten sposób możliwe jest
57 natychmiastowy podgląd aplikacji, ze wszystkimi funkcjami narzędzi do
58 projektowania aplikacjia, takimi jak eksportem diagramów funkcji,
59 refaktoryzacji zorientowanych obiektowo aplikacji, czy automatycznego
60 generowania kodu.
61
62 PHP_UML:
63  - przetwarzanie relacji klas, interfejsów, dziedziczenia i
64    implementacji,
65  - przetwarzanie właściwości, stałych, widoczności i stałych atrybutów
66    klas,
67  - przetwarzanie funkcji, ich parametrów, zwracanych funkcji i typów
68    (jeśli określone),
69  - przetwarzanie komentarzy docblook : komentarzy klas (@package),
70    funkcji (@param i @return) i nagłówków plików (@package),
71  - interpretacja instrukcji przestrzeni nazw PHP ("namespace" i "use"),
72  - autoamtyczna detekcja typu z pomocą domyślnych wartości,
73  - generowania UML w wersji 1.4 i 2.1
74  - generowanie widoków logicznych, komponentów.
75
76 Ta klasa ma w PEAR status: %{_status}.
77
78 %prep
79 %pear_package_setup
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{php_pear_dir}
84 %pear_package_install
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc install.log docs/PHP_UML/{docs,examples}
92 %{php_pear_dir}/.registry/*.reg
93 %{php_pear_dir}/PHP/UML
94 %{php_pear_dir}/PHP/UML.php
95 %{php_pear_dir}/data/PHP_UML
This page took 0.365529 seconds and 3 git commands to generate.