]> git.pld-linux.org Git - SPECS.git/blob - php-indeyets-pake.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / php-indeyets-pake.spec
1 %define         status          stable
2 %define         pearname        pake
3 Summary:        %{pearname} - PHP automation tool with capabilities similar to make
4 Name:           php-indeyets-pake
5 Version:        1.7.2
6 Release:        1
7 License:        BSD license
8 Group:          Development/Languages/PHP
9 Source0:        http://pear.indeyets.ru/get/%{pearname}-%{version}.tgz
10 # Source0-md5:  0678184f4493e45bc32105a2a2134d91
11 URL:            https://github.com/indeyets/pake/wiki
12 BuildRequires:  php-channel(pear.indeyets.ru)
13 BuildRequires:  php-packagexml2cl
14 BuildRequires:  php-pear-PEAR >= 1:1.4.1
15 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
16 BuildRequires:  rpmbuild(macros) >= 1.654
17 Requires:       php(pcre)
18 Requires:       php-channel(pear.indeyets.ru)
19 Requires:       php-pear
20 Requires:       php-symfony-YAML
21 Suggests:       php(bz2)
22 Suggests:       php(mbstring)
23 Suggests:       php(pcntl)
24 Suggests:       php(phar)
25 Suggests:       php(posix)
26 Suggests:       php(svn)
27 Suggests:       php(yaml)
28 Suggests:       php(zlib)
29 Suggests:       php-pear-PEAR
30 Suggests:       php-phing
31 Suggests:       php-simpletest
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # exclude optional dependencies
36 %define         _noautoreq_pear PEAR/.* PEAR2/Autoload.php phing/Phing.php simpletest/.*
37
38 %description
39 Pake is a command line utility for executing predefined tasks,
40 inspired by make. It is written in PHP and the tasks are also
41 described in PHP.
42
43 Pake supports tasks with prerequisites. Pake can be bundled with your
44 application as a single phar archive (or even as a single PHP file),
45 end users don’t need to install Pake on their systems.
46
47 Pake can be used for compiling projects from different pieces,
48 generating code, preprocessing templates and deploying projects.
49
50 In PEAR status of this package is: %{status}.
51
52 %prep
53 %pear_package_setup
54 mv docs/pake/* .
55
56 %build
57 packagexml2cl package.xml > ChangeLog
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_pear_dir}}
62 %pear_package_install
63 install -p ./%{_bindir}/* $RPM_BUILD_ROOT%{_bindir}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post -p <lua>
69 %pear_package_print_optionalpackages
70
71 %files
72 %defattr(644,root,root,755)
73 %doc LICENSE ChangeLog install.log optional-packages.txt
74 %{php_pear_dir}/.registry/.channel.*/*.reg
75 %attr(755,root,root) %{_bindir}/pake
76 %{php_pear_dir}/pake.php
77 %{php_pear_dir}/pake
This page took 0.461805 seconds and 3 git commands to generate.