]> git.pld-linux.org Git - SPECS.git/blob - perl-cardreader.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-cardreader.spec
1 #
2 # Conditional build
3 %bcond_with     tests   # perform "make test" (requires reader)
4 #
5 Summary:        Perl extension for TLP and RFTLP SmartCard reader
6 Summary(pl.UTF-8):      Rozszerzenie Perla do czytników kart procesorowych TLP i RFTLP
7 Name:           perl-cardreader
8 Version:        1.0.0
9 Release:        2
10 License:        BSD-like + restricted vendor's name usage (see copyright file)
11 Group:          Libraries
12 Source0:        http://www.gemplus.com/techno/tlp_drivers/download/libtlp-perl_%{version}.tar.gz
13 # Source0-md5:  12caa3e41d2e5635d3274549600cd8da
14 URL:            http://www.gemplus.com/techno/tlp_drivers/
15 BuildRequires:  libtlp-devel
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Perl extension for TLP and RFTLP SmartCard reader.
22
23 %description -l pl.UTF-8
24 Rozszerzenie Perla do czytników kart procesorowych TLP i RFTLP.
25
26 %prep
27 # use -c, the name "perl" may be too common
28 %setup -q -c
29
30 %build
31 cd perl
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make} \
35         CC="%{__cc}" \
36         OPTIMIZE="%{rpmcflags} -I."
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 cd perl
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc perl/{Changes,README.unix,debian/copyright}
53 %{perl_vendorarch}/cardreader.pm
54 %dir %{perl_vendorarch}/auto/cardreader
55 %attr(755,root,root) %{perl_vendorarch}/auto/cardreader/*.so
56 %{_mandir}/man3/*
This page took 0.900207 seconds and 3 git commands to generate.