]> git.pld-linux.org Git - SPECS.git/blob - perl-Tree-Simple.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Tree-Simple.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Tree
6 %define         pnam    Simple
7 Summary:        Tree::Simple - A simple tree object
8 Summary(pl.UTF-8):      Tree::Simple - obiekt prostego drzewa
9 Name:           perl-Tree-Simple
10 Version:        1.18
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  70462938108a8b8658b1b1d2f12dbeab
17 URL:            http://search.cpan.org/dist/Tree-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Exception >= 0.15
22 BuildRequires:  perl-Test-Simple >= 0.47
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module in an fully object-oriented implementation of a simple
29 n-ary tree. It is built upon the concept of parent-child
30 relationships, so therefore every Tree::Simple object has both a
31 parent and a set of children (who themselves may have children, and so
32 on). Every Tree::Simple object also has siblings, as they are just the
33 children of their immediate parent.
34
35 It is can be used to model hierarchal information such as a
36 file-system, the organizational structure of a company, an object
37 inheritance hierarchy, versioned files from a version control system
38 or even an abstract syntax tree for use in a parser. It makes no
39 assumptions as to your intended usage, but instead simply provides the
40 structure and means of accessing and traversing said structure.
41
42 %description -l pl.UTF-8
43 Ten moduł to w pełni obiektowo zorientowana implementacja prostego
44 drzewa n-arnego. Jest zbudowany w oparciu i ideę relacji
45 rodzic-dziecko, tak że każdy obiekt Tree::Simple ma rodzica oraz zbiór
46 dzieci (które też mogą mieć dzieci, i tak dalej). Każdy obiekt
47 Tree::Simple ma także rodzeństwo - czyli dzieci bezpośredniego
48 rodzica.
49
50 Moduł może być używany do informacji o modelu hierarchicznym, takich
51 jak system plików, struktura organizacyjna firmy, hierarchia
52 dziedziczenia obiektów, wersjonowane pliki z systemu kontroli wersji
53 czy nawet abstrakcyjne drzewo składniowe do używania w parserze. Moduł
54 nie czyni żadnych założeń co do wykorzystania, ale po prostu dostarcza
55 strukturę oraz metody dostępu i przechodzenia po strukturze.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %{perl_vendorlib}/Tree/*.pm
80 %{perl_vendorlib}/Tree/Simple
81 %{_mandir}/man3/*
This page took 0.36908 seconds and 3 git commands to generate.