]> git.pld-linux.org Git - SPECS.git/blob - perl-Tree-RedBlack.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / perl-Tree-RedBlack.spec
1 %define         pdir    Tree
2 %define         pnam    RedBlack
3 Summary:        Tree::RedBlack - Perl implementation of Red/Black tree, a type of balanced tree
4 Summary(pl.UTF-8):      Tree::RedBlack - implementacja perlowa drzew czerwono-czarnych
5 Name:           perl-Tree-RedBlack
6 Version:        0.5
7 Release:        1
8 License:        Artistic
9 Group:          Development/Languages/Perl
10 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
11 # Source0-md5:  46a749fa2aa047d5a044ecf0a0fbc925
12 URL:            http://search.cpan.org/dist/Tree-RedBlack/
13 BuildRequires:  perl-devel >= 1:5.8.0
14 BuildRequires:  rpm-perlprov >= 4.1-13
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is a Perl implementation of the Red/Black tree algorithm found in
20 the book "Algorithms", by Cormen, Leiserson & Rivest (more commonly
21 known as "CLR" or "The White Book"). A Red/Black tree is a binary tree
22 which remains "balanced" - that is, the longest length from root to a
23 node is at most one more than the shortest such length. It is fairly
24 efficient; no operation takes more than O(lg(n)) time.
25
26 %description -l pl.UTF-8
27 To jest perlowa implementacja algorytmu drzew czerwono-czarnych, którą
28 można znaleźć w książce "Algorithms" autorstwa Cormena, Leisersona i
29 Rivesta (częściej znanej jako "CLR" lub "Biała księga"). Drzewo
30 czerwono-czarne to binarne drzewo, które pozostaje wyważone - czyli
31 najdłuższa droga od korzenia do liścia jest najwyżej o jeden dłuższa
32 od najkrótszej. Jest dość wydajne; żadna operacja nie trwa dłużej niż
33 O(log(n)).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/Tree/RedBlack.pm
56 %{perl_vendorlib}/Tree/RedBlack
57 %{_mandir}/man3/*
This page took 0.106681 seconds and 3 git commands to generate.