]> git.pld-linux.org Git - SPECS.git/blob - perl-Tree-DAG_Node.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / perl-Tree-DAG_Node.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Tree
6 %define         pnam    DAG_Node
7 Summary:        Tree::DAG_Node - (super)class for representing nodes in a tree
8 Summary(pl.UTF-8):      Tree::DAG_Node - (nad)klasa do reprezentowania węzłów w drzewie
9 Name:           perl-Tree-DAG_Node
10 Version:        1.31
11 Release:        1
12 License:        Artistic v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tgz
15 # Source0-md5:  d870334364d399bf5214a1b841be73ee
16 URL:            http://search.cpan.org/dist/Tree-DAG_Node/
17 BuildRequires:  perl-devel >= 1:5.8.1
18 %if %{with tests}
19 BuildRequires:  perl(File::Spec) >= 3.40
20 BuildRequires:  perl-File-Slurp-Tiny >= 0.003
21 BuildRequires:  perl-File-Temp >= 0.19
22 BuildRequires:  perl-Test-Simple >= 1.001_014
23 BuildRequires:  perl-Test-Pod >= 1.48
24 %endif
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This class encapsulates/makes/manipulates objects that represent nodes
31 in a tree structure. The tree structure is not an object itself, but
32 is emergent from the linkages you create between nodes. This class
33 provides the methods for making linkages that can be used to build up
34 a tree, while preventing you from ever making any kinds of linkages
35 which are not allowed in a tree (such as having a node be its own
36 mother or ancestor, or having a node have two mothers).
37
38 %description -l pl.UTF-8
39 Ta klasa obudowuje, tworzy i obrabia obiekty, które reprezentują węzły
40 w strukturze drzewiastej. Struktura drzewiasta jako taka nie jest
41 obiektem, ale wyłania się z połączeń tworzonych pomiędzy węzłami. Ta
42 klasa udostępnia metody do tworzenia połączeń, które mogą być używane
43 do zbudowania drzewa, nie dopuszczając na zrobienie połączeń nie
44 dozwolonych w drzewie (takich jak połączenie węzła z jego przodkiem,
45 lub nadanie węzłowi dwóch przodków).
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/Tree/DAG_Node.pm
70 %{_mandir}/man3/Tree::DAG_Node.3pm*
This page took 0.038838 seconds and 3 git commands to generate.