]> git.pld-linux.org Git - SPECS.git/blob - perl-Test-ManyParams.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-Test-ManyParams.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Test
6 %define         pnam    ManyParams
7 Summary:        Test::ManyParams - module to test many params as one test
8 Summary(pl.UTF-8):      Test::ManyParams - moduł do testowania wielu parametrów podczas jednego testu
9 Name:           perl-Test-ManyParams
10 Version:        0.10
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ba8534916c50206985beda77720c671b
17 URL:            http://search.cpan.org/dist/Test-ManyParams/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Readonly
22 BuildRequires:  perl-Set-CrossProduct
23 BuildRequires:  perl-Test-Builder-Tester
24 BuildRequires:  perl-Test-Differences
25 BuildRequires:  perl-Test-Exception
26 BuildRequires:  perl-Test-Simple
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module helps to tests many parameters at once. In general, it
33 calls the given subroutine with every combination of the given
34 parameter values. The combinations are created with building a cross
35 product.
36
37 %description -l pl.UTF-8
38 Ten moduł jest pomocny przy testowania wielu parametrów naraz.
39 Ogólnie, wywołuje on podaną funkcję we wszystkich kombinacjach
40 podanych wartości parametrów. Kombinacje są tworzone poprzez iloczyn
41 kartezjański.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %{perl_vendorlib}/%{pdir}/*.pm
65 %{_mandir}/man3/*
This page took 0.937835 seconds and 3 git commands to generate.