]> git.pld-linux.org Git - SPECS.git/blob - perl-Taint-Util.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-Taint-Util.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Taint
6 %define         pnam    Util
7 Summary:        Taint::Util - Test for and flip the taint flag without regex matches or eval
8 Summary(pl.UTF-8):      Taint::Util - sprawdzanie i zmiana flagi skażenia bez wyrażeń regularnych ani eval
9 Name:           perl-Taint-Util
10 Version:        0.08
11 Release:        8
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Taint/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  4f081a8a6e82352741c0486784cbc23d
17 URL:            https://metacpan.org/dist/Taint-Util
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.11
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Simple
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Taint::Util wraps Perl's internal routines for checking and setting
29 the taint flag and thus does not rely on regular expressions for
30 untainting or odd tricks involving eval and kill for checking whether
31 data is tainted, instead it checks and flips a flag on the scalar
32 in-place.
33
34 %description -l pl.UTF-8
35 Taint::Util obudowuje wewnętrzne procedury Perla do sprawdzania i
36 ustawiania flagi skażenia, dzięki czemu nie polega na wyrażeniach
37 regularnych w celu usuwania flagi lub brzydkich sztuczkach z eval i
38 kill w celu sprawdzenia, czy dane są skażone - zamiast tego sprawdza
39 i przełącza flagę zmiennych skalarnych w miejscu.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc ChangeLog
65 %dir %{perl_vendorarch}/Taint
66 %{perl_vendorarch}/Taint/Util.pm
67 %dir %{perl_vendorarch}/auto/Taint
68 %dir %{perl_vendorarch}/auto/Taint/Util
69 %attr(755,root,root) %{perl_vendorarch}/auto/Taint/Util/Util.so
70 %{_mandir}/man3/Taint::Util.3pm*
This page took 0.313286 seconds and 3 git commands to generate.