]> git.pld-linux.org Git - SPECS.git/blob - perl-Sys-Syscall.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Sys-Syscall.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Sys
6 %define pnam    Syscall
7 Summary:        Sys::Syscall - access system calls that Perl doesn't normally provide access to
8 Summary(pl.UTF-8):      Sys::Syscall - dostęp do wywołań systemowych, do których sam Perl nie daje dostępu
9 Name:           perl-Sys-Syscall
10 Version:        0.25
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  720a9ec5f67f867814a9011b2a725763
16 URL:            http://search.cpan.org/dist/Sys-Syscall/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Use epoll, sendfile, from Perl. Mostly Linux-only support now, but
24 more syscalls/OSes planned for future.
25
26 %description -l pl.UTF-8
27 Ten moduł pozwala używać wywołania takie jak epoll czy sendfile z
28 poziomu Perla. Jak na razie obsługiwane są w większości wywołania
29 tylko linuksowe, ale w przyszłości planowana jest obsługa większej
30 liczby wywołań i systemów operacyjnych.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc CHANGES
54 %{perl_vendorlib}/Sys/*.pm
55 %{_mandir}/man3/*
This page took 0.080195 seconds and 3 git commands to generate.