]> git.pld-linux.org Git - SPECS.git/blob - perl-SOAP-WSDL.spec
SPECS updated Sat 31 Jul 21:27:02 CEST 2021
[SPECS.git] / perl-SOAP-WSDL.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %define         pdir    SOAP
6 %define         pnam    WSDL
7 Summary:        SOAP::WSDL - SOAP with WSDL support
8 Name:           perl-SOAP-WSDL
9 Version:        2.00.10
10 Release:        2
11 License:        GPL
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 # Source0-md5:  c3f97ffae56881be65907ee9b4efa222
15 URL:            http://soap-wsdl.sourceforge.net/
16 BuildRequires:  perl-Class-Std-Fast
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-Template-Toolkit
19 BuildRequires:  perl-Term-ReadKey
20 BuildRequires:  perl-TimeDate
21 BuildRequires:  perl-XML-Parser
22 BuildRequires:  perl-modules
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreq      perl(SOAP::WSDL::Header)
28
29 %description
30 SOAP::WSDL provides easy access to Web Services with WSDL
31 descriptions. The WSDL is parsed and stored in memory. Your data is
32 serialized according to the rules in the WSDL. The only transport
33 mechanisms currently supported are http and https.
34
35 %package examples
36 Summary:        SOAP::WSDL - examples
37 Group:          Development/Languages/Perl
38
39 %description examples
40 Examples for SOAP::WSDL.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58 cp -a example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 # don't package .pod
61 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/SOAP/WSDL/*.pod
62 rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/SOAP/WSDL/Manual
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README TODO
70 %attr(755,root,root) %{_bindir}/wsdl2perl.pl
71 %{perl_vendorlib}/SOAP/*.pm
72 %{perl_vendorlib}/SOAP/WSDL
73 %{_mandir}/man3/SOAP*
74 %{_mandir}/man1/wsdl2perl.pl.1p*
75
76 %files examples
77 %defattr(644,root,root,755)
78 %{_examplesdir}/%{name}-%{version}
This page took 0.275181 seconds and 3 git commands to generate.