]> git.pld-linux.org Git - SPECS.git/blob - perl-Parse-RPM-Spec.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / perl-Parse-RPM-Spec.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Parse
6 %define         pnam    RPM-Spec
7 Summary:        Parse::RPM::Spec - Perl extension to parse RPM spec files
8 Name:           perl-Parse-RPM-Spec
9 Version:        0.08
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Parse/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  247aadd8017bbd5f058e79fe3d43302c
16 URL:            http://search.cpan.org/dist/Parse-RPM-Spec/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Moose)
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 RPM is the package management system used on Linux distributions based
28 on Red Hat Linux. These days that includes Fedora, Red Hat Enterprise
29 Linux, Centos, SUSE, Mandriva and many more.
30
31 RPMs are build from the source of a packages along with a spec file.
32 The spec file controls how the RPM is built.
33
34 This module creates Perl objects which module spec files. Currently it
35 gives you simple access to various pieces of information from the spec
36 file.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Build.PL \
43         destdir=$RPM_BUILD_ROOT \
44         installdirs=vendor
45 ./Build
46
47 %{?with_tests:./Build test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 ./Build install
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %dir %{perl_vendorlib}/Parse/RPM
61 %{perl_vendorlib}/Parse/RPM/Spec.pm
62 %{_mandir}/man3/Parse::RPM::Spec.3pm*
This page took 0.11326 seconds and 3 git commands to generate.