]> git.pld-linux.org Git - SPECS.git/blob - perl-Parallel-Prefork.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / perl-Parallel-Prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Parallel
6 %define         pnam    Prefork
7 Summary:        Parallel::Prefork - A simple prefork server framework
8 Name:           perl-Parallel-Prefork
9 Version:        0.18
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Parallel/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  128f8c03eddde44d3e95f092d6116e9a
16 URL:            http://search.cpan.org/dist/Parallel-Prefork/
17 BuildRequires:  perl-Module-Install
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Accessor::Lite) >= 0.04
22 BuildRequires:  perl(Proc::Wait3) >= 0.03
23 BuildRequires:  perl(Scope::Guard)
24 BuildRequires:  perl-List-MoreUtils
25 BuildRequires:  perl-Signal-Mask
26 BuildRequires:  perl-Test-Requires
27 BuildRequires:  perl-Test-SharedFork
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Parallel::Prefork is much like Parallel::ForkManager, but supports
34 graceful shutdown and run-time reconfiguration.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/Parallel/*.pm
59 %{perl_vendorlib}/Parallel/Prefork
60 %{_mandir}/man3/*
This page took 0.141301 seconds and 3 git commands to generate.