]> git.pld-linux.org Git - SPECS.git/blob - perl-Package-Stash-XS.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-Package-Stash-XS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Package
6 %define         pnam    Stash-XS
7 Summary:        Package::Stash::XS - faster and more correct implementation of the Package::Stash API
8 Summary(pl.UTF-8):      Package::Stash::XS - szybsza i bardziej poprawna implementacja API Package::Stash
9 Name:           perl-Package-Stash-XS
10 Version:        0.29
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Package/Package-Stash-XS-%{version}.tar.gz
16 # Source0-md5:  e5b58846a01aa39c36605e071c306dcc
17 URL:            https://metacpan.org/release/Package-Stash-XS
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-Test-Fatal
24 BuildRequires:  perl-Test-Simple >= 0.88
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is a backend for Package::Stash, which provides the functionality
30 in a way that's less buggy and much faster. It will be used by default
31 if it's installed, and should be preferred in all environments with a
32 compiler.
33
34 %description -l pl.UTF-8
35 Ten moduł jest backendem dla modułu Package::Stash, udostępniającym
36 jego funkcjonalność w mniej błędny i szybszy sposób. Jest używany jako
37 domyślny backend jeśli jest zainstalowany i powinien być preferowany
38 we wszystkich środowiskach z kompilatorem.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make} \
47         CC="%{__cc}" \
48         OPTIMIZE="%{rpmcflags}"
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %dir %{perl_vendorarch}/Package
65 %dir %{perl_vendorarch}/Package/Stash
66 %{perl_vendorarch}/Package/Stash/XS.pm
67 %dir %{perl_vendorarch}/auto/Package
68 %dir %{perl_vendorarch}/auto/Package/Stash
69 %dir %{perl_vendorarch}/auto/Package/Stash/XS
70 %attr(755,root,root) %{perl_vendorarch}/auto/Package/Stash/XS/XS.so
71 %{_mandir}/man3/Package::Stash::XS.3pm*
This page took 0.148113 seconds and 3 git commands to generate.