]> git.pld-linux.org Git - SPECS.git/blob - perl-POE-Component-DirWatch.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / perl-POE-Component-DirWatch.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    POE
6 %define         pnam    Component-DirWatch
7 Summary:        POE::Component::DirWatch - POE directory watcher
8 Summary(pl.UTF-8):      POE::Component::DirWatch - obserwowanie katalogów w POE
9 Name:           perl-POE-Component-DirWatch
10 Version:        0.300000
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0cb83b9405b43955988d0461333b5a45
17 URL:            http://poe.perl.org/
18 BuildRequires:  perl-File-Signature
19 BuildRequires:  perl-Moose >= 0.24
20 BuildRequires:  perl-MooseX-Types-Path-Class
21 BuildRequires:  perl-POE >= 0.12
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 POE::Component::DirWatch watches a directory for files. It creates a
29 separate session which invokes a user-supplied callback as soon as if
30 finds a file in the directory. Its primary intended use is processing
31 a "drop-box" style directory, such as an FTP upload directory.
32
33 %description -l pl.UTF-8
34 POE::Component::DirWatch obserwowuje katalog pod kątem plików. Tworzy
35 oddzielną sesję, która wywołuje przekazane przez użytkownika wywołanie
36 zwrotne zaraz jak znajdzie w katalogu plik. Głównym zastosowaniem jest
37 przetwarzanie katalogów służących do wrzucania plików, takich jak
38 katalog upload dostępny przez FTP.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorlib}/POE/Component/DirWatch.pm
64 %dir %{perl_vendorlib}/POE/Component/DirWatch
65 %{perl_vendorlib}/POE/Component/DirWatch/*.pm
66 %dir %{perl_vendorlib}/POE/Component/DirWatch/Role
67 %{perl_vendorlib}/POE/Component/DirWatch/Role/*.pm
68 %{_mandir}/man3/*
This page took 0.44005 seconds and 3 git commands to generate.