]> git.pld-linux.org Git - SPECS.git/blob - perl-POE-Component-AIO.spec
SPECS updated Sun 1 Aug 15:50:02 CEST 2021
[SPECS.git] / perl-POE-Component-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    POE
6 %define pnam    Component-AIO
7 Summary:        POE::Component::AIO - Asynchronous Input/Output for POE
8 #Summary(pl.UTF-8):     
9 Name:           perl-POE-Component-AIO
10 Version:        1.00
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  27449af8deb647f17be209abe2e9e9e8
16 URL:            http://search.cpan.org/dist/POE-Component-AIO/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-IO-AIO
21 BuildRequires:  perl-POE
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This component adds support for IO::AIO use in POE
28
29 # %description -l pl.UTF-8
30 # TODO
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} pure_install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/POE/Component/*.pm
58 #%%{perl_vendorlib}/POE/Component/AIO
59 %{_mandir}/man3/*
60 %{_examplesdir}/%{name}-%{version}
This page took 0.199189 seconds and 3 git commands to generate.