]> git.pld-linux.org Git - SPECS.git/blob - perl-Module-ScanDeps.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / perl-Module-ScanDeps.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Module
6 %define         pnam    ScanDeps
7 Summary:        Module::ScanDeps - recursively scan Perl programs for dependencies
8 Summary(pl.UTF-8):      Module::ScanDeps - rekurencyjne wyszukiwanie zależności programów perlowych
9 Name:           perl-Module-ScanDeps
10 Version:        1.24
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  353763269196b6232b71b84e1f9d8c5d
17 URL:            http://search.cpan.org/dist/Module-ScanDeps/
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-File-Temp
22 BuildRequires:  perl-Module-Metadata
23 BuildRequires:  perl-PathTools
24 BuildRequires:  perl-Test-Requires
25 BuildRequires:  perl-Test-Simple
26 BuildRequires:  perl-version
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 An application of Module::ScanDeps is to generate executables from
33 scripts that contains necessary modules; this module supports two such
34 projects, PAR and App::Packer.  Please see their respective
35 documentations on CPAN for further information.
36
37 %description -l pl.UTF-8
38 Zastosowanie Module::ScanDeps to generowanie ze skryptów plików
39 wykonywalnych zawierających wszelkie potrzebne skryptowi moduły.  Ten
40 moduł wspiera dwa takie projekty: PAR i App::Packer. Więcej informacji
41 można znaleźć w ich dokumentacji w CPAN.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc AUTHORS Changes README
65 %attr(755,root,root) %{_bindir}/scandeps.pl
66 %{perl_vendorlib}/Module/ScanDeps.pm
67 %{perl_vendorlib}/Module/ScanDeps
68 %{_mandir}/man1/scandeps.pl.1p*
69 %{_mandir}/man3/Module::ScanDeps.3pm*
This page took 0.109947 seconds and 3 git commands to generate.