]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-BigInteger.spec
SPECS updated Sun 1 Aug 20:28:02 CEST 2021
[SPECS.git] / perl-Math-BigInteger.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Math
6 %define         pnam    BigInteger
7 Summary:        Math::BigInteger - arbitrary length integer extension module for Perl
8 Summary(pl.UTF-8):      Math::BigInteger - moduł rozszerzenia liczb całkowitych dowolnej długości
9 Name:           perl-Math-BigInteger
10 Version:        1.01
11 Release:        18
12 # if used in a product, Systemics should be given attribution
13 License:        free use, distributable
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a4aa79e070f3f5f8e7f01443fdc03b8e
17 Patch0:         %{name}-Fputc_to_fputc.patch
18 URL:            http://search.cpan.org/dist/Math-BigInteger/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Math::BigInteger module gives access to Eric Young's bignum library.
25 This provides a faster alternative to the Math::BigInt library.
26
27 %description -l pl.UTF-8
28 Moduł Math::BigInteger umożliwia dostęp do biblioteki bignum Erica
29 Younga. Jest to szybsza alternatywa dla biblioteki Math::BigInt.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33 %patch0 -p0
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README COPYRIGHT
56 %{perl_vendorarch}/Math/BigInteger.pm
57 %dir %{perl_vendorarch}/auto/Math/BigInteger
58 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInteger/BigInteger.so
59 %{_mandir}/man3/*
This page took 0.183369 seconds and 3 git commands to generate.