]> git.pld-linux.org Git - SPECS.git/blob - perl-Math-BigInt-Constant.spec
SPECS updated Sat 31 Jul 20:26:02 CEST 2021
[SPECS.git] / perl-Math-BigInt-Constant.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Math
6 %define         pnam    BigInt-Constant
7 Summary:        Math::BigInt::Constant - arbitrary sized constant integers
8 Summary(pl.UTF-8):      Math::BigInt::Constant - stałe całkowite o dowolnym rozmiarze
9 Name:           perl-Math-BigInt-Constant
10 Version:        1.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a62d900bcbb2ea84cfb69a557d4bf0a8
17 URL:            http://search.cpan.org/dist/Math-BigInt-Constant/
18 BuildRequires:  perl(Math::BigFloat) >= 1.26
19 BuildRequires:  perl-Math-BigInt >= 1.74
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 Requires:       perl(Math::BigFloat) >= 1.26
23 Requires:       perl-Math-BigInt >= 1.74
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module lets you define constant BigInts on a per-object basis.
29 The usual "use Math::BigInt ':constant'" will catch all integer
30 constants in the script at compile time, but will not let you create
31 constant values on the fly, nor work for strings and/or floating point
32 constants like "1e5".
33
34 %description -l pl.UTF-8
35 Ten moduł pozwala definiować stałe BigInty dla każdego obiektu. Zwykłe
36 "use Math::BigInt ':constant'" wyłapie wszystkie stałe całkowite w
37 skrypcie w czasie kompilacji, ale nie pozwoli na tworzenie stałych
38 wartości w locie, ani nie będzie działać z łańcuchami czy stałymi
39 zmiennoprzecinkowymi typu "1e5".
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc BUGS CHANGES LICENSE README TODO
63 %{perl_vendorlib}/Math/BigFloat/Constant.pm
64 %{perl_vendorlib}/Math/BigInt/Constant.pm
65 %{_mandir}/man3/*
This page took 2.034313 seconds and 3 git commands to generate.