]> git.pld-linux.org Git - SPECS.git/blob - perl-JSON-RPC.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-JSON-RPC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    JSON
6 %define         pnam    RPC
7 Summary:        JSON::RPC - JSON RPC 2.0 Server Implementation
8 #Summary(pl.UTF-8):     
9 Name:           perl-JSON-RPC
10 Version:        1.01
11 Release:        0.1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/JSON/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  802d5bb488f3587f16aa69e8c002132b
17 URL:            http://search.cpan.org/dist/JSON-RPC/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Class::Accessor::Lite)
22 BuildRequires:  perl(JSON)
23 BuildRequires:  perl(Plack)
24 BuildRequires:  perl(Router::Simple)
25 BuildRequires:  perl-libwww
26 BuildRequires:  perl(Plack::Request)
27 BuildRequires:  perl(Plack::Test)
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 JSON::RPC is a set of modules that implment JSON RPC 2.0 protocol.
34
35     If you are using old JSON::RPC code (up to 0.96), DO NOT EXPECT
36     YOUR CODE TO WORK WITH THIS VERSION. THIS VERSION IS 
37     ****BACKWARDS INCOMPATIBLE****
38
39
40
41 # %description -l pl.UTF-8
42 # TODO
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/JSON/*.pm
67 %{perl_vendorlib}/JSON/RPC
68 %{_mandir}/man3/*
This page took 0.626189 seconds and 3 git commands to generate.