]> git.pld-linux.org Git - SPECS.git/blob - perl-Inline-Tcl.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Inline-Tcl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Inline
6 %define         pnam    Tcl
7 Summary:        Inline::Tcl - Write Perl subroutines in Tcl
8 Summary(pl.UTF-8):      Inline::Tcl - pisanie procedur Perla w Tcl-u
9 Name:           perl-Inline-Tcl
10 Version:        0.09
11 Release:        5
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Inline/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  c3f0a7852196b68a89128e54ce381f07
16 URL:            http://search.cpan.org/dist/Inline-Tcl/
17 BuildRequires:  perl-Inline >= 0.40
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  tcl-devel >= 8.3.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Inline::Tcl Perl module allows you to put Tcl source code directly
25 "inline" in a Perl script or module. A Tcl interpreter is loaded and
26 the Tcl code is interpreted, then Perl asks the Tcl interpreter which
27 global procedures have been defined. Those functions are made
28 available to your Perl program as if they had been written in Perl.
29
30 %description -l pl.UTF-8
31 Moduł Perla Inline::Tcl pozwala na umieszczanie kodu źródłowego w
32 Tcl-u bezpośrednio w skryptach lub modułach perlowych. Wczytywany jest
33 interpreter Tcl-a, który interpretuje kod, a następnie Perl odpytuje
34 go, jakie procedury globalne zostały zdefiniowane. Funkcje te są
35 udostępniane programowi w Perlu tak, jakby były napisane w Perlu.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL </dev/null \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Bugs Changes README
61 %{perl_vendorarch}/Inline/Tcl.pm
62 %dir %{perl_vendorarch}/auto/Inline/Tcl
63 %attr(755,root,root) %{perl_vendorarch}/auto/Inline/Tcl/Tcl.so
64 %{_mandir}/man3/*
This page took 0.061442 seconds and 3 git commands to generate.