]> git.pld-linux.org Git - SPECS.git/blob - perl-IPC-ChildSafe.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-IPC-ChildSafe.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    IPC
6 %define         pnam    ChildSafe
7 Summary:        IPC::ChildSafe - control a child process without blocking
8 Summary(pl.UTF-8):      IPC::ChildSafe - sterowanie procesem potomnym bez blokowania
9 Name:           perl-IPC-ChildSafe
10 Version:        3.16
11 Release:        15
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IPC/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  68f9ae8be45c7399272a26bbe86d12ba
17 URL:            http://search.cpan.org/dist/IPC-ChildSafe/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 IPC::ChildSafe Perl module allows to control a child process without
24 blocking. It addresses the "blocking problem" inherent in most
25 coprocessing designs such as IPC::Open3.
26
27 %description -l pl.UTF-8
28 Moduł Perla IPC::ChildSafe umożliwia sterowanie procesem potomnym bez
29 blokowania. Rozwiązuje "problem blokowania" dziedziczony przez
30 większość rozwiązań wieloprocesowych, takich jak IPC::Open3.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/IPC/*.pm
60 %dir %{perl_vendorarch}/auto/IPC/ChildSafe
61 %attr(755,root,root) %{perl_vendorarch}/auto/IPC/ChildSafe/ChildSafe.so
62 %{_mandir}/man3/*
63 %{_examplesdir}/%{name}-%{version}
This page took 0.562232 seconds and 3 git commands to generate.