]> git.pld-linux.org Git - SPECS.git/blob - perl-HTTP-Server-Simple.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-HTTP-Server-Simple.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %define pdir    HTTP
6 %define pnam    Server-Simple
7 Summary:        HTTP::Server::Simple - Lightweight HTTP server
8 Summary(pl.UTF-8):      HTTP::Server::Simple - Lekki serwer HTTP
9 Name:           perl-HTTP-Server-Simple
10 Version:        0.52
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        https://cpan.metacpan.org/authors/id/B/BP/BPS/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1e23935491d9a2a8b0ba636462255656
17 URL:            http://search.cpan.org/dist/HTTP-Server-Simple/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a simple standalone HTTP server. By default, it doesn't thread
25 or fork. It does, however, act as a simple frontend which can be used
26 to build a standalone web-based application or turn a CGI into one.
27 It's possible to use Net::Server to get threading, forking, preforking
28 and so on. Autrijus Tang wrote the functionality and owes docs for
29 that.
30
31 %description -l pl.UTF-8
32 HTTP::Server::Simple jest prostym, samodzielnym serwerem HTTP.
33 Domyślnie nie obsługuje on wątków i podprocesów, jednakże może
34 byc użyty jako frontend do budowy samodzielnej aplikacji WWW lub jako
35 CGI. Możliwe jest użycie modułu Net::Server do obsługi wątków,
36 podprocesów itp. z wykorzystaniem kodu stworzonego przez Autrijusa
37 Tanga.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/HTTP/Server
62 %{_mandir}/man3/*
This page took 0.037548 seconds and 3 git commands to generate.