]> git.pld-linux.org Git - SPECS.git/blob - perl-GraphViz-Makefile.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-GraphViz-Makefile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    GraphViz
6 %define         pnam    Makefile
7 Summary:        Create Makefile graphs using GraphViz
8 Summary(pl.UTF-8):      Tworzenie grafów z plików Makefile wykorzystując GraphViz
9 Name:           perl-GraphViz-Makefile
10 Version:        1.16
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b80f835000ad3adee6d82ab38a2feb4e
17 URL:            http://search.cpan.org/dist/GraphViz-Makefile/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Make)
22 BuildRequires:  perl-GraphViz
23 %endif
24 Requires:       perl-Tk
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Create Makefile graphs using GraphViz.
30
31 %description -l pl.UTF-8
32 Tworzenie grafów z plików Makefile wykorzystując GraphViz.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %attr(755,root,root) %{_bindir}/tkgvizmakefile
58 %{perl_vendorlib}/GraphViz/Makefile.pm
59 %{_mandir}/man3/*
60 %{_mandir}/man1/*
This page took 0.149592 seconds and 3 git commands to generate.