]> git.pld-linux.org Git - SPECS.git/blob - perl-Find-Lib.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / perl-Find-Lib.spec
1 #
2 # TODO: - fix "make test"
3 #       - pl
4 #
5 # Conditional build:
6 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
7 %bcond_with     tests           # do not perform "make test"
8 #
9 %define         pdir    Find
10 %define         pnam    Lib
11 Summary:        Find::Lib - helper to smartly find libs to use in the filesystem tree
12 Name:           perl-Find-Lib
13 Version:        1.04
14 Release:        1
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://search.cpan.org/CPAN/authors/id/Y/YA/YANNK/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  bf5619b4ba1945320eccef69b028c453
20 URL:            http://search.cpan.org/dist/Find-Lib/
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Helper to smartly find libs to use in the filesystem tree.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35
36 %{__make}
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} pure_install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes README
52 %{_mandir}/man3/Find::Lib.3pm*
53 %dir %{perl_vendorlib}/Find
54 %{perl_vendorlib}/Find/Lib.pm
This page took 0.794918 seconds and 3 git commands to generate.