]> git.pld-linux.org Git - SPECS.git/blob - perl-Filesys-Virtual-Async-Dispatcher.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-Filesys-Virtual-Async-Dispatcher.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    Filesys
6 %define pnam    Virtual-Async-Dispatcher
7 Summary:        perl(Filesys::Virtual::Async::Dispatcher)
8 Name:           perl-Filesys-Virtual-Async-Dispatcher
9 Version:        0.01
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Filesys/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  de5133e55de1250f1e4a0d1d1bb47112
16 URL:            http://search.cpan.org/dist/Filesys-Virtual-Async-Dispatcher/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Filesys::Virtual::Async)
21 BuildRequires:  perl-Test-Simple >= 0.86
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module allows you to have arbitrary combinations of
28 Filesys::Virtual::Async objects mounted and expose a single
29 filesystem. The dispatcher will correctly map methods to the proper
30 object based on their path in the filesystem. This works similar to
31 the way linux manages mounts in a single "visible" filesystem.
32
33 It might be a bit confusing on how the paths work at first. I'm sure
34 with a bit of experimentation and looking at the documentation for the
35 Filesys::Virtual::Async::XYZ subclass, you'll get it!
36
37 This module makes extensive use of the functions in File::Spec to be
38 portable, so it might trip you up if you are developing on a linux box
39 and trying to mount '/foo' on a win32 box :)
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Build.PL \
46         destdir=$RPM_BUILD_ROOT \
47         installdirs=vendor
48 ./Build
49
50 %{?with_tests:./Build test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 ./Build install
56
57 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/Filesys/Virtual/Async/*.pm
67 #%%{perl_vendorlib}/Filesys/Virtual/Async/Dispatcher
68 %{_mandir}/man3/*
69 %{_examplesdir}/%{name}-%{version}
This page took 0.112849 seconds and 3 git commands to generate.