]> git.pld-linux.org Git - SPECS.git/blob - perl-File-KeePass.spec
SPECS updated Sat 31 Jul 20:27:02 CEST 2021
[SPECS.git] / perl-File-KeePass.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    File
6 %define         pnam    KeePass
7 Summary:        File::KeePass - Interface to KeePass V1 and V2 database files
8 Name:           perl-File-KeePass
9 Version:        2.03
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  085da6ef1ada886ca3e9b8724fc213b3
16 URL:            http://search.cpan.org/dist/File-KeePass/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Crypt::Rijndael) >= 1.0
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 File::KeePass gives access to KeePass version 1 (kdb) and version 2
27 (kdbx) databases.
28
29 The version 1 and version 2 databases are very different in
30 construction, but the majority of information overlaps and many
31 algorithms are similar. File::KeePass attempts to iron out as many of
32 the differences.
33
34 File::KeePass gives nearly raw data access. There are a few utility
35 methods for manipulating groups and entries. More advanced
36 manipulation can easily be layered on top by other modules.
37
38 File::KeePass is only used for reading and writing databases and for
39 keeping passwords scrambled while in memory. Programs dealing with UI
40 or using of auto-type features are the domain of other modules on
41 CPAN. File::KeePass::Agent is one example.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} pure_install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorlib}/File/*.pm
66 #{perl_vendorlib}/File/KeePass
67 %{_mandir}/man3/*
This page took 0.332253 seconds and 3 git commands to generate.