]> git.pld-linux.org Git - SPECS.git/blob - perl-File-Flat.spec
SPECS updated Sun 1 Aug 20:13:02 CEST 2021
[SPECS.git] / perl-File-Flat.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define         pdir    File
7 %define         pnam    Flat
8 Summary:        File::Flat - implements a flat filesystem
9 Summary(pl.UTF-8):      File::Flat - implementacja płaskiego systemu plików
10 Name:           perl-File-Flat
11 Version:        1.07
12 Release:        1
13 # "same as perl"
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/File/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2e58179a4cc6d8fdacaa8e5224b3414d
18 URL:            https://metacpan.org/release/File-Flat
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with autodeps} || %{with tests}
23 BuildRequires:  perl(File::Spec) >= 0.85
24 BuildRequires:  perl-File-Copy-Recursive >= 0.35
25 BuildRequires:  perl-File-Remove >= 0.38
26 BuildRequires:  perl-File-Temp >= 0.17
27 BuildRequires:  perl-Test-ClassAPI >= 1.04
28 BuildRequires:  perl-Test-Simple >= 0.47
29 BuildRequires:  perl-prefork >= 0.02
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 File::Flat implements a flat filesystem. A flat filesystem is a
36 filesystem in which directories do not exist. It provides an
37 abstraction over any normal filesystem which makes it appear as if
38 directories do not exist. In effect, it will automatically create
39 directories as needed. This is created for things like install scripts
40 and such, as you never need to worry about the existance of
41 directories, just write to a file, no matter where it is.
42
43 %description -l pl.UTF-8
44 File::Flat implementuje płaski system plików. Płaski system plików to
45 taki, w którym nie istnieją katalogi. Moduł udostępnia abstrakcję
46 ponad każdym normalnym systemem plików, powodującą, że zachowuje się,
47 jakby katalogi nie istniały. W efekcie automatycznie tworzy wszystkie
48 potrzebne katalogi. Służy do rzeczy takich jak skrypty instalacyjne i
49 inne, żeby nie trzeba było się martwić o istnienie katalogów -
50 wystarczy po prostu pisać do pliku, nie ważne gdzie on jest.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} pure_install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %{perl_vendorlib}/File/Flat.pm
76 %{_mandir}/man3/File::Flat.3pm*
This page took 0.047444 seconds and 3 git commands to generate.