]> git.pld-linux.org Git - SPECS.git/blob - perl-ExtUtils-Command.spec
SPECS updated Sun 1 Aug 11:02:02 CEST 2021
[SPECS.git] / perl-ExtUtils-Command.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    ExtUtils
6 %define pnam    Command
7 Summary:        Shell::Command - Cross-platform functions emulating common shell commands
8 Summary(pl.UTF-8):      Shell::Command - wieloplatformowe funkcje emulujące popularne polecenia powłoki
9 Name:           perl-ExtUtils-Command
10 Version:        1.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/ExtUtils/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8d2bd6a2311b6264d3dd96c11601c34a
17 URL:            http://search.cpan.org/dist/ExtUtils-Command/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.31
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The module is used to replace common UNIX commands. In all cases the
26 functions work from @ARGV rather than taking arguments. This makes
27 them easier to deal with in Makefiles.
28
29 %description -l pl.UTF-8
30 Ten moduł ma na celu zastąpienie popularnych poleceń uniksowych. We
31 wszystkich przypadkach funkcje działają z @ARGV zamiast przyjmowania
32 argumentów - dzięki temu są łatwiejsze do obsługi w plikach Makefile.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         destdir=$RPM_BUILD_ROOT \
40         installdirs=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/ExtUtils/Command.pm
57 %{_mandir}/man3/ExtUtils::Command.3pm*
This page took 0.144951 seconds and 3 git commands to generate.